Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2011
    Posts
    6

    Default Dimension 652 A/V meter trouble.

    Hello everyone, I'm a longtime lurker on the forum. I picked up a new machine to power my carbon arc torch. It's a Dimension 652, serial# LB092486. It seems to weld stick fine, and pushes the CAC great, but it has a problem with the display gauges. When the unit is turned on, the voltage reads 74 and amps read -1 or-2. This is displayed no matter where the A/V adjust knob is set. If I hook up a footpedal, and switch to remote it drops to 0 vollts, but as soon as you click the foot pedal to any setting other than off voltage climbs to 74. The arc responds to different knob settings, but the meters don't. I probably can't afford to take it in for repair, I would really hope that I can troubleshoot and repair it myself.
    I have an oscilloscope, and can do some basic testing. I just don't have access to the tech manual. There is nothing obvious on either circuit board, and all connections are clean and tight.Any suggestions or ideas would be really appreciated.
    Steve.

  2. #2
    Join Date
    Oct 2004
    Location
    Edmonton, Alberta
    Posts
    8,347

    Default

    Occiliscope, been at this for 20 plus years, think I pulled out a Scope only a couple times. Your machine merely needs a calibration for the idiot Gage's. And that's all they are. Zero to do with actual welding.

  3. #3
    Join Date
    Aug 2011
    Posts
    6

    Default

    I like the sound of that, how do i do the calibration?

  4. #4
    Join Date
    Oct 2004
    Location
    Edmonton, Alberta
    Posts
    8,347

    Default

    You'd probably could zero the meters out yourself, but to calibrate it, you'd need a tech and a load bank

  5. #5
    Join Date
    Aug 2011
    Posts
    6

    Default

    Just getting the meters to respond to the dial would be good enough for me. It's more a case of it bugging me that they don't work than it is of caring about the accuracy of the readout. I'm afraid that if there is a glitch in the meter circuit, then how do I know that something else isn't working right. I know, I'm OCD, I should just be glad that it welds right, haha. Thanks for the responses

  6. #6
    Join Date
    Aug 2011
    Posts
    6

    Default

    Quote Originally Posted by cruizer View Post
    Occiliscope, been at this for 20 plus years, think I pulled out a Scope only a couple times. Your machine merely needs a calibration for the idiot Gage's. And that's all they are. Zero to do with actual welding.
    Haha, that's because "techs" nowadays are a step above trained monkeys. Their solution to everything is either buy a new board, or trash the welder. Until welder manufacturers switch to surface mount technology, there is a whole generation of circuit boards in these welders that have easily replaced components. I can sit and test components for hours and still save money over the cost of an entire board. Of course if decent tech manuals were available, it would really speed things up. Of course I understand Miller's perspective: better to sell a new $5000 welder than a $30 tech manual and a 30 cent diode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 79

Welding Projects

Special Offers: See the latest Miller deals and promotions.