Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Aug 2010
    Location
    Chesapeake, Va
    Posts
    108

    Default Lincoln Vantage popping the 120 breakers when running my miller 304xmt off of it?

    My 2010 Lincoln vantage was giving me trouble yesterday I was welding with another guy and he was using the leads off of the vantage and I was running the miller 304 off of the 240 plug. We were both burning 1/8 7018 rods at about 120amps the machine was bogging down or welding bad at all but it kept popping the 120 breakers we both had 11 amp Milwaukee grinders but neither one of use were using the grinders while welding . It didn't pop the 50 amp breaker so I know I wasn't over loading it?
    Lincoln Vantage Kubota diesel 30 amp spool gun , Hobart 210 with spool gun, Thermal dynamic pak master 75, miller 304xmt all mobile all ready to go.

  2. #2
    Join Date
    Aug 2004
    Location
    Milan Michigan
    Posts
    1,730

    Default

    This is a Miller site so we shouldn't know anything about a Vantage, Accept that its a lot like the Pipe Pro 304 but runs around 1800 RPM and puts out 12000 watts of power if I remember correctly.

    You should not have had any problems. Your wording wasn't very good so maybe I miss under stood you,
    Sounds like you need to have it fixed.

  3. #3
    Join Date
    Jul 2008
    Location
    Flin Flon & Creighton area
    Posts
    233

    Default machine grounding?

    Just read your post, Do you have the Vantage grounded to the Chassis of whatever your are hauling it in? Regardless of the branding of a machine i think this is a small factor many people overlook. Next question is if the 120 outlets on that machine are GFCI type out lets or do you have any cords that might be GFCI that could be part of the problem? Finally i would assume your grinders are compatible with ac/dc operation? I had a grinder that wasnt one time years ago on a lincoln sa200 that supplied dc power to the plug in outlet, it worked when plugged in once, then smoked the grinder. Most of the newer grinders are built to accommodate this, but on the chance id consider it. Might not hurt to check all the extension cords you were using too, any issues might present themselves causing the breakers to pop. Hope this might help, if not post another thread aimed at Cruizer, he is the man and can probly get you sorted out
    I have a welding addiction

    ...the only stupid question is the one you didn't ask

  4. #4
    Join Date
    Aug 2010
    Location
    Chesapeake, Va
    Posts
    108

    Default

    I have not had any issue with the breakers popping when I was just using the machine with leads but when I was using it to power the 304 and welding at the same time it was popping the breakers. The machine is not grounded to the the trailer It is on . So I will do that and see if it helps. I started the thread just because I know cruizer is on here and knows his stuff. I know it is a miller site but cruiser knows more about the engine drives then people on other sites. All of my cords are in good condition and my grinders are new milwaukees which haven't given me any trouble besides this incident. So I know it has something to do with powering the 304 off the vantage.
    Lincoln Vantage Kubota diesel 30 amp spool gun , Hobart 210 with spool gun, Thermal dynamic pak master 75, miller 304xmt all mobile all ready to go.

  5. #5
    Join Date
    Feb 2012
    Posts
    226

    Default

    Cruzier will know but he is just busy we are lucky he comes by when he has time. I know we all really appreciate him and Duane they are top notch.

  6. #6
    Join Date
    Aug 2004
    Location
    Milan Michigan
    Posts
    1,730

    Default

    Question about your Vantage, Do you run wire off of it and if so how do you like it.

    I always thought it might be a comparable machine to the Miller pipe Pro 304 but with a slower revving engine.

  7. #7
    Join Date
    Aug 2010
    Location
    Chesapeake, Va
    Posts
    108

    Default

    Don't run wire off of it just run a stick machine, plasma cutter, or my Hobart 210 off of it.
    Lincoln Vantage Kubota diesel 30 amp spool gun , Hobart 210 with spool gun, Thermal dynamic pak master 75, miller 304xmt all mobile all ready to go.

  8. #8
    Join Date
    Dec 2007
    Location
    Los Angeles
    Posts
    2,890

    Default

    Popping Breaker or the GFI on the receptacle?
    Ed Conley
    http://www.screamingbroccoli.net/
    MM252
    MM211
    Passport Plus w/Spool Gun
    TA185
    Miller 125c Plasma 120v
    O/A set
    SO 2020 Bender
    You can call me Bacchus

  9. #9
    Join Date
    Aug 2010
    Location
    Chesapeake, Va
    Posts
    108

    Default

    Gfi on the receptacle. I grounded the machine to the trailer today so hopefully that will fix it.
    Lincoln Vantage Kubota diesel 30 amp spool gun , Hobart 210 with spool gun, Thermal dynamic pak master 75, miller 304xmt all mobile all ready to go.

  10. #10

    Default

    I Do exactly what your talking about all the time with my vantage 500's and XMT 350s'. never had a problem

    I would start looking at all your coards and plugs for faults.

    All i run anymore is wire in CV and i LOVE my vantage

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 82

Welding Projects

Special Offers: See the latest Miller deals and promotions.