Hi,

I was on a job a week ago tig welding on a pontoon boat. I was on my last two beads when suddenly I got no welding power when I stepped on the remote pedal. To make this brief, I checked the breakers, they were OK and checked all the connections,they were fine too. I tried in local mode on both the HF unit and the Trail Blazer's panel bypassing the contactor and nothing. I get gas and the HF spark that jumps to ground, that's it.

I went to stick mode (by passing the HF unit altogether) and finished the job with some aluminum rod I carry for situations where only a rod will work. I'm stumped.

With the help of some members of another welders forum I ran through some basic tests to try and narrow down the problem.

1) I tested for 24 volt ac in pins A & G 14 pin connecter on the Trailblazer. It was good.
2) I tested for welding output by connecting pins A & B on the 14 pin connector on the Trailblazer while in remote mode. It was good also.
3) On my remote HF unit (HF251-d) I tested for continuity between pins A & B when pressing on the pedal. It was good.
4) I tested each of the five wires from the remote to the 14 pin connector for continuity and they were all good.
5) I found that if I connected the remote directly to the front panel of the TB, I had full amperage control when using the foot pedal. If I connect the remote to the HF unit, I get no welding power.
6) I had a spare HF unit that was working fine until I put it in storage. It is the same model except it has the remote contactor installed as it was used on an older AED200LE with no internal contactor. It also failed to work.

The machine is producing welding current and sending it out to the welding lugs.
The remote foot pedal and works fine if connected directly to the TB. Two different remote HF units failed. The TB is behaving as if there is an internal "sensor" of some type that detects when a remote HF unit is installed that has gone bad as I cannot explain why two identical units failed with the identical symptoms.

I tried both HF units in all combinations to seek if I could get welding current out of them. In local mode, remote mode no welding current passes through them. I don't know what else to do.

Anyone have an idea?

Thanks,

Tony

Tony