Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 5 of 5

Hybrid View

  1. #1
    Join Date
    Oct 2013
    Posts
    1

    Default Digital Elite problem ; seeing triple while welding

    Hello
    I purchased a new digital elite the other day. The first job I put it to the test with was a small gouge and weld job. The hood was working great but after the 3rd 4" arcair pass i started to see triple and it has never came back to normal. The hood was never any closer than 2' to the arc and did not get hot, just as a note. I have replaced all the lenses and made sure they were in proper. Also, I heard that a way to stop the illusion is to flip the shade in the rubber surround so it will be closer to the outer cover lense but this did not work; I have also tryed covering up the back of the hood so no outside light could get in but that did not work either. The only way I could get the illusion to stop was while welding use my finger and push the outer cover lense (bend it) closer to the shade, but when i release my finger the lense comes back out and the illusion returns.

    Any advice would be greatly appreciated
    -Matt

  2. #2
    Join Date
    Jul 2010
    Location
    Salem, NJ
    Posts
    271

    Default

    I just bought a new digital elite helmet to replace of of my 2 I already own and I have to say first that the headgear sucks balls. Its cheap, chinsy, flimsy, crap as far as a fabricator goes. It sucks putting on and off in a regular basis, BUT, it is very comfortable to wear for long periods of time. So this I say is a welder headgear, not a fabricators headgear. The lens is nice. I always loved the X mode for welding outside.

    With my last helmet, (3 years old), it would work fine and then everything would drop by 50-60% shade wise. So welding at 10, it would just drop to a 4 or 5 with 10 still shown. I changed out the batteries twice with proper miller and no help. Power off for 3 minutes works for a few minutes, then back to 50%.

    I have also had times where I have seen 3 actions before. It was during welding and plasma cutting. All I ever did was to power off the helmet, remove batteries for 3 minutes and reinstall and it worked fine. I never had a shade problem, and it wasn't caused from a crooked lens. It seemed as though the 2 sides of the lens didn't smoothly come together and created "shadows"

  3. #3
    Join Date
    Nov 2003
    Posts
    2,983

    Default

    Quote Originally Posted by mattmcc View Post
    Hello
    I purchased a new digital elite the other day. The first job I put it to the test with was a small gouge and weld job. The hood was working great but after the 3rd 4" arcair pass i started to see triple and it has never came back to normal. The hood was never any closer than 2' to the arc and did not get hot, just as a note. I have replaced all the lenses and made sure they were in proper. Also, I heard that a way to stop the illusion is to flip the shade in the rubber surround so it will be closer to the outer cover lense but this did not work; I have also tryed covering up the back of the hood so no outside light could get in but that did not work either. The only way I could get the illusion to stop was while welding use my finger and push the outer cover lense (bend it) closer to the shade, but when i release my finger the lense comes back out and the illusion returns.

    Any advice would be greatly appreciated
    -Matt
    MATT

    Brand New??...sounds like you may have a defective cartridge... I would call Miller and see if they can replace it under warranty...
    .

    *******************************************
    The more you know, The better you know, How little you know......

    “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

    Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

    My Blue Stuff:
    Dynasty 350DX Tigrunner
    Dynasty 200DX
    Millermatic 350P w/25ft Alumapro & 30A
    Millermatic 200

    TONS of Non-Blue Equip, plus Mills, Lathes & a Rat Tail File..

  4. #4
    Join Date
    Apr 2014
    Posts
    1

    Default same problem

    Quote Originally Posted by mattmcc View Post
    Hello
    I purchased a new digital elite the other day. The first job I put it to the test with was a small gouge and weld job. The hood was working great but after the 3rd 4" arcair pass i started to see triple and it has never came back to normal. The hood was never any closer than 2' to the arc and did not get hot, just as a note. I have replaced all the lenses and made sure they were in proper. Also, I heard that a way to stop the illusion is to flip the shade in the rubber surround so it will be closer to the outer cover lense but this did not work; I have also tryed covering up the back of the hood so no outside light could get in but that did not work either. The only way I could get the illusion to stop was while welding use my finger and push the outer cover lense (bend it) closer to the shade, but when i release my finger the lense comes back out and the illusion returns.

    Any advice would be greatly appreciated
    -Matt





    did you solve your problem ? my Digital Elite have the same trouble .
    i try a another cartridge and still the same .

    thank you

  5. #5
    Join Date
    Mar 2014
    Location
    puyallup, wa
    Posts
    12

    Default

    I have an elite....hate it, I put it back in the box and it sits on the shelf. get a huntsman 1105vxl and a hood to put it in. The best hood you will ever use. I've had mine for a long time and will cry if it ever dies.http://www.365-safety.com/huntsman-a...FROVfgodJyIARg

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 62

Welding Projects

Special Offers: See the latest Miller deals and promotions.

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 137