Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 3 of 3

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Posts
    1

    Default Spectrum 375 x-treme power light blinking

    Earlier in the year, I bought my spectrum 375 x-treme plasma cutter. I used it twice. Today, It will not operate. Machine turns on, when I pull the trigger the power light starts to blink.
    Things I've checked and verified:
    Voltage is 240v also tried on the 110v plug
    pressure is within range and have adjusted it from 90-130 psi.
    tips, etc are brand new miller
    moisture trap inside machine is fine

    I have looked all of the older posts on this machine with similar problems and have come up with nothing. Any help would be greatly appreciated!

  2. #2
    Join Date
    Mar 2010
    Location
    Ceres, California
    Posts
    358

    Default

    Double check that you have 240 volts getting to the unit.
    Check trouble shooting grid in your owners manual.
    If under warranty take to warranty shop for repair.
    Glenn 300 amp stick
    Millermatic 35
    L-tec plasma

  3. #3
    Join Date
    Oct 2004
    Location
    Edmonton, Alberta
    Posts
    7,910

    Default

    There are 3 of the x-treme 375 units, maybe serial# would be handy....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 82

Welding Projects

Special Offers: See the latest Miller deals and promotions.