Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2010
    Posts
    19

    Default Bobcat 225 let us down today

    We were out on a job with our Bobcat 225 today welding up some grate frames. We tacked the pieces of the first frame together but when we started to weld them up, we had no power output. The welder had been running for maybe 20 min. and the engine was running fine and was never shut off. We went from having output power to not having output power like someone had flipped a switch. And I mean no power to the leads or the 120 or 240 outlets.
    We've been using this machine for quite a while with no problems till now. I opened up the unit and saw no obvious problems, the brushes were ok on the slip rings, the fuse wasn't blown, no burned up wires, nothing obvious. Anyone got any troubleshooting tips?

  2. #2
    Join Date
    Sep 2009
    Location
    South Carolina
    Posts
    570

    Default

    oh man, I hate to hear that. I would sell a kidney to get a new 225.

  3. #3
    Join Date
    Feb 2012
    Posts
    226

    Default

    You may have to clean those fuses and holders had some problems with contact on mine

  4. #4
    Join Date
    Dec 2010
    Posts
    19

    Default Sure it's nothing major

    I'll be checking things more thoroughly this weekend. I'm sure it's something simple as quickly as it stopped working. But we did have to back up and punt after she stopped working! I do want to get it fixed asap, however, since e use it fairly often. But I can't complain, we got a super deal on it when we bought it and we've had no trouble out of it till now.

  5. #5
    Join Date
    Dec 2010
    Posts
    300

    Default

    Quote Originally Posted by Kpack View Post
    You may have to clean those fuses and holders had some problems with contact on mine
    must be something in the air i was on a pipe job the other day on a rig and some guys was useing one of them miller 140 engine driven welders and all of a sudden no power .the engene ran fine no blown fuses that we could find we cleaned all the contacts with clp blew it out real good and still nuthing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Non-static method PhpQuickProfiler::getMicroTime() should not be called statically in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/pqp/classes/Console.php on line 77

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 82

Welding Projects

Special Offers: See the latest Miller deals and promotions.