What am I up against here?

Purchased a well used Miller Legend gas driven.
Knowing it has problems. PO let me know it was not generating weld current.
Serial # KD481281 Stock # 903039

But it was only $500 bucks. And the engine runs well. Soworst case. I could use the engine on a John Deere garden tractor. And make thegamble pay off.
But I would prefer to have a Portable welder. As long as thecost of repair parts is reasonable.

Took the covers off today. Found a few items (visually) thatdo not look right.

I took a few photos of damage found.
I knew the bottom of the welder was rusty. But it is worsethan bad.
And the Laminated Iron core of the Stabilizer & Reactorare falling apart. And there is a small board just hanging in space?

There appears there was some heat around the DC + outputlug. As the red plastic is discolored. Thinking someone let the welding cablebecome loose in the past.

Right away I noticed what looks like a damaged Capacitor orDiode?
I am not sure as it looks like it is split in 2 parts. The 2parts hanging on the ends of white wires is round and black in color. Like 2tiny little hockey pucks.
One end is wired to the T-1 terminal strip.
And is connected to the bottom of T-1 E.
And the other half is connected to a wire leading to theupper spade on CB4 Circuit Breaker auto reset 24Vdc 7A.

Is this infact an in-line diode? That has split in half?

I have the Technical Manual TM-428A.
And in the parts section of the book. On page 79 item # 10 is a diode but is unclearwhere it is connected?

This machine has 3 Diode looking devices. Hanging in line inthis same area.
Just not clear what I am dealing with.

I see D4, D5 & D6 in the drawing Fig 9-12 page 54.
Am I correct thinking I am dealing with D6 34B(CB4) that isdamaged?


Am I on the right track? Or all wet?