Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 10 of 11

Hybrid View

  1. #1
    Join Date
    Oct 2012
    Posts
    6

    Default millermatic 250 problem

    howdy from north ga. i have a millermatic250 i bought new & used around the shop on hotrods & farm equip. i started to use it this week & it is acting up.
    i had to replace the "sheath" that the solid wire runs thu. wire was kinking
    up at times and could not get voltage to regulate. acts like a stick welder does
    when the amperage is turned up WAY WAY to high. it will arc but not matter what i try it is so hot i cannot weld with it. i tried adjusting gas flow,wrte speed
    and voltage but cannot change the situation. i pulled side off to b sure a mouse or dirt-dobber had not got inside. everything appears to be intact-not wires off or
    signs of problems. any help would be appreciated. retired power co mechanic,
    used several welders during the years but love my miller. reccomend them to all my buds. thanks BILL

  2. #2
    Join Date
    Oct 2004
    Location
    Edmonton, Alberta
    Posts
    7,233

    Default

    IS gas going through, I think you have a failed gun

  3. #3
    Join Date
    Jun 2012
    Location
    Tracy, CA
    Posts
    205

    Default

    I had a similar symptoms a few weeks ago. Turned out someone put a new spool of wire on and they loaded it so it was feeding from the top. After I put the spool on right it fed like a charm. Imagine that.
    Trailblazer® 302 Air Pak™
    Miller Dynasty® 350
    Millermatic 350P Aluminum
    Millermatic® 252
    Syncrowave 351

    SuitCase® X-TREME™ 12VS

    Multimatic™ 200
    Millermatic® 211 Auto-Set™ w/MVP™
    XR-Aluma Pro Gun
    Diversion™ 180

    Spectrum® 625 X-TREME™

    Thermal Dynamics® Cutmaster® 52
    Victor Oxy/Acetylene Set

  4. #4
    Join Date
    Oct 2012
    Posts
    6

    Default

    u can hear gas at the nozzle when u pull trigger. wire is rolling off from the bottom. guage flucuates when trigger is pulled so i'm pretty sure it's working.

  5. #5
    Join Date
    Oct 2004
    Location
    Edmonton, Alberta
    Posts
    7,233

    Default

    I have a sneeking suspicion that the gas liner in the gun is busted, and your pulling atmospheric into it, to get the welds that your talking about,

  6. #6
    Join Date
    Oct 2012
    Posts
    6

    Default problem

    i assume you are talking about where the wire comes out of the gun/ i had a new one installed yesterday. i also thougt my wire might be too contaminated as it
    has been in machine long time. roll i started with was "spotty" had little places
    that looked like rust. put brand new roll of wire in today but no change. thanks
    tribble

  7. #7
    Join Date
    Oct 2012
    Posts
    6

    Default millermatic 250

    i had a new liner put in yesterday. also put new roll of wirein. u can hear gas when u put gun close and pull the trigger. guage flucuates when u pull trigger also

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Welding Projects

Special Offers: See the latest Miller deals and promotions.