Hi Guys,

I need your help again.

I had a problem with my Dynasty 300DX about a year ago, it was working perfectly in DC until I tried to weld some aluminium in AC. It started acting up and a long story short, I sent it overseas to get it repaired since there is no Miller tech centre where I live (MALTA , Europe ) , they changed the IGBTs and got it back working perfectly. I only did like 2 hours of welding ever since I got it back, now it stopped working again.

I was welding some 304 stainless steel tubing, did about 4 inches of welding , stopped to turn the work piece. Went into position to start an arc on HF and pressed the pedal.... nothing happened !!! I was like what's wrong??? I checked ground, was ok, resharpened the tunsgsten, but still no arc. Checked all settings and all was ok. Then I had the idea of trying to start an arc on lift mode, but had no luck. Then I changed tungsten and tried on A/C and acted the same... no arc start which ever setting I tried. I also noticed that the high bzzz sound that makes when on HF start inside the machine, its not making it any more. Pre flow and post flow works ok.

What I am noticing it doing is, when the pre flow time ends, it makes a click from the display area and the display says 0.6 and 500 and no arc happens. Then I lift off the pedal and post flow time starts ok and gas flows ok. On Lift arc, when I lift the tungsten, I hear the click but again, no arc. It looks like it lost all weld output and the HF noise that it used to make inside the machine has stopped aswell.

Can you please help me out... I would appreciate it if maybe you guys could help me find out what's wrong. I have to spend money again to send the machine overseas for repair again. so if possibly there will be something I might check before I fork the money out again it would be great. Tech guy in his email said it could be an output diode but to be 100% certain he have to check the machine, which is 1500 miles away!!

Your help will be greatly appreciated.

Best regards,
Marlon