Hi, sorry for the long post here...

OK, I was using my millermatic 135 today. I broke it out for a project I'm doing. It was sitting for about 6 months. 3 months in the back of my pickup (in the cab) and 3 months in the basement.

Anyway, I started welding and had some trouble with a lot of popping.. I realized it was my breaker, and swapped it out... So now I was getting a good powerful weld.. nice.. HOWEVER, now I was having trouble with the bead.. looked like I wasn't getting any gas. So I checked my tank and it was full open, and the tank was full. I thought maybe my metal had some paint residue that was causing the problem, so cleaned the surface real good with my angle grinder and laid another bead. Same thing!!

So I went to my tank and there is a separate flow valve that controls the flow... You know, its a philips head screw with a nut situated right between the gagues.. I loosened the nut and turned the screw to the right.. a bit too much actually as I turned it all the way it could go.. and I heard a loud hissing noise.. so I backed it off until I couldn't hear the gas come out any more.

I thought at this point I should have enough gas (CO2/Argon) to get a good bead.. I tried again, and same thing... looked like no gas was coming out. So now I notice my LPM gague is at ZERO, but my PSI is at something like 1500.

So, I disconnected the valve from my bottle and reattached. The gagues went back to normal.. phew!

I picked up the gun, pulled the trigger, heard a loud poping noise from the nozzle, then, no gas.

No matter what I do, I can't get the Argon/CO2 to come out of my nozzle. I actually pulled the clear tube from the fitting that feeds the gas into the welding cable/gun assembly to see if anything is coming out, and nothing. I put my finger over it and pulled the trigger.. nothing... so I think I can safetly say its not a clogged nozzle... even though I took the nozzle off and tried as well.

Any help is greatly appreciated. I have this project that must get done ASAP.

Thank you all.
Paul