Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums
 
Miller Welding Discussion Forums - Powered by vBulletin

Results 1 to 3 of 3

Hybrid View

  1. #1
    ozymyx Guest

    Question Plasma Cutter Problem

    Ok, so I am the proud owner of a new Miller Spectrum 125C - my first plasma cutter.

    Works great - well it did....So I was happily practicing cutting steel and anything else I could get my hands on in my workshop for hours and hours, no problems. Saturday 10pm I stop. Put down the torch, turned it off, went upstairs to family.

    Sunday night, turn on the cutter, put the torch on the metal I wanted to cut, pulled trigger...<tink> breakers go for the room. Ok, flip breaker, try again, same story. In the end I work out that just pulling the trigger on the torch trips the breaker. Hmmm. Decide that it's something to do with voltage drops. So I get an extension cord, run it to another room and plug the cutter in. This time I get to the point where the first sparks come out of the other side of the metal and...now the fault light comes on the cutter it stops but the breaker doesn't trip. I checked the voltage on the socket - 118.

    Between Sat night and Sunday night NOTHING changed, I didn't do anything..could it be the (new) cutter ? My crappy wiring ? Both ?

    any suggestions welcome, I'm dying to get back to cutting !

    thanks
    Andrew

  2. #2
    Join Date
    Sep 2005
    Posts
    100

    Default

    Is it at all possible you have excessive moisture coming through your airline?
    Not sure if this would cause the problem, but it is the #1 problem with plasma cutters.

  3. #3
    Join Date
    Aug 2006
    Location
    near rochester NY
    Posts
    9,881

    Default

    you might try changeing out the consumables. i know its strange but i have the same cutter, well mine is about 5 or so years old now but still the 125C.
    also dont tighten it down too much when you put on a new tip.

    what size extention cord are you using and how far is it going ? ny time i use a extention cord its always a 12gage cord and i try to stick to 50' or less but have used a 100' one a few times. again all were 12 gage cords. never little chepo 14 or 16 gage cords. i can run my 125C plasma or my MM135 off the 100' 12gage if needed but as i say i try to stick to 50' or less i have 2 each 25' 12gage cords i like to stick to.

    also make shore you have a good ground.
    keep us posted.
    thanks for the help
    ......or..........
    hope i helped

    feel free to shoot me an e-mail direct i have time to chat. james@newyorkmetalart.com
    summer is here, plant a tree. if you don't have space or time to plant one sponsor some one else to plant one for you. a tree is an investment in our planet, help it out.
    JAMES

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Warning: Function split() is deprecated in /mnt/stor3-wc1-dfw1/357822/357839/www.millerwelds.com/web/content/lib/footer.inc.php on line 82

Welding Projects

Special Offers: See the latest Miller deals and promotions.