Announcement

Collapse
No announcement yet.

User Profile

Collapse
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • The tungsten was deteriorating badly.
    In fact with the last go around the tungsten was almost welded to the gas lens as well as being severely burned back.

    But, I think I found the problem, or at least it is fixed for now.
    I had tried a new gas lens, new nozzle, and even a new...
    See more | Go to post

    Leave a comment:


  • Good suggestion and if I had another torch I would do that. This thing has me puzzled.
    It was welding fine for several years and now suddenly it hisses when the arc is first struck.
    I will have to keep looking at it I guess.
    perry...
    See more | Go to post

    Leave a comment:


  • I will check, but when I press down on the foot pedal gas flows for a half second or so then the arc starts, along with the hiss and flash.
    That tells me gas is flowing so there should be a silent start to the arc. The hiss and flash make me think air is being induced with the gas flow.
    ...
    See more | Go to post

    Leave a comment:


  • I always have my pre-flow set at the same setting and that has not been changed.
    See more | Go to post

    Leave a comment:


  • I have a good quality welding helmet (Lincoln Arctic, I think).
    And yes, quickly making a second weld the hiss still occurs.

    This is a recent problem,. starting yesterday.
    . I weld a lot of aluminum and steel with this helmet and the flash only happens when the 2024 helmet battery...
    See more | Go to post

    Leave a comment:


  • piniongear
    started a topic Need an opinion or advice.....

    Need an opinion or advice.....

    I have a Dynasty 200DX running a WP250 -20 water cooled torch.
    Using Argon gas and welding 1/8 inch steel.

    My problem is when I first start welding there a bright flash and a short loud hissing sound coming from the torch.
    Quickly the hiss stops and all is quiet and the weld...
    See more | Go to post

  • piniongear
    replied to any ideas
    I have a Dynasty 200 myself and have no experience with your problem.
    However, when there is an operational problem the volt meter will read HEP (for HELP) and the amp meter will display a P-0 through a P-21 number which will relate to a specific problem.
    If you have no metes lit up, I think...
    See more | Go to post

    Leave a comment:

No activity results to display
Show More

Profile Sidebar

Collapse
piniongear
piniongear
Senior Member
Last Activity: 09-09-2016, 06:29 PM
Joined: 07-24-2008
Location: Houston TX
Working...
X