Announcement

Collapse
No announcement yet.

troubleshooting a dead dynasty 300

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • troubleshooting a dead dynasty 300

    I've got a dead dynasty 300, older unit with knob controls. Plugged in and switched on rear panel turned on I get nothing, no sound, no clicking, no readout. I can follow voltage thru to the SCR where voltage changes to DC, but don't know enough to go further. Is there a fuse or something simple I'm forgetting? It will be my first time using this model machine, moving from a powcon 300. There may indeed be something wrong with this machine as we acquired it with assets of another firm and I don't know anything about its history but I'd like to try to get it running myself before I send it in for service.
    Any ideas?

    T

  • #2
    Sorry I can't help you, my Dynasty is too new. I wasn't aware they were made with dial controls. Does the older unit have autolink? Possibly the older 300 needs to be set up for the incoming voltage manually.
    Jonny

    Dynasty 300DX
    Esab PCM 1000

    Comment


    • #3
      I took another look at the machine again today and tried it on 3 phase current, and the display lit up. First it gave help12 error for almost everything (improper setup) but the next time I tried it all functions worked. I went back to single phase and still nothing. I'm guessing that maybe somebody replaced the power cord at some time and may have put the red conductor in the wrong position, which would mean the controls are getting no power during single phase operation in which just the black and white conductors are used. I'll swap some wires around tomorrow and see what happens, hopefully that is the problem. If the machine was being used on 3ph current the color coding of the cord would make no difference but with 1ph it sure does..

      t

      Comment


      • #4
        if its three phase could it be out of phase? my guess is look up a wiring diagram which could be inside a cover.. but ive never seen one so im not sure.
        Yea, I am 7'2... No, I do not play basketball!

        Comment


        • #5
          God I hate powcons! Ive had nothing but bad luck with them. One blew one time in the shop and it blew all the fuses in the shop (all were in good order and all wirering done by a certified electrition) and destroyed a power transformer outside feeding the surrounding areas. No one includining the electric company could figure out what happened. They did figure out though that for unknown reasons it sent welding output current through the imput lines

          Comment

          Working...
          X