Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

The forum is currently undergoing maintenance and is in a 'read-only' mode for the time being. Sorry for the inconvenience.


  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

problems with my 150 stl

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problems with my 150 stl

    sorry if this is in the wrong section, hopefully the admin can move it if it is.

    anyway i have a maxstar 150 stl welder. iv been using it as a stick welder since i bought it and decided to try tig welding. i bought the regualtor tourch and gas but im having some problems. the welder works fine when im stick weldign but when i select the lift start the ready light wont light up (doesnt blink or anything). the lift start indcator lights up but nothing else. no spark, no arc, nothing. then i switch it back to stick and it works perfectly. am i doing something wrong or is my welder broken?

  • #2
    Interesting...

    Possibility: There are three settings on the 150STL: Stick, Lift-arc TIG and Ift-arc TIG remote. If you are selecting Tig remote, the welder is probably waiting on the foot pedal to be depressed before being ready. Or, I could be wrong.

    Comment


    • #3
      YES YES YES were getting somewhere. looked up the pin indetification and connected pin 1 to pin 2 and heard the solenoid pop open and i was able to strike an arc! so i looks like for the most part things are working. now i need to figure out how to show the machine that there is no remote connect so it opens the valve byitself. any ideas??

      trigger, man great idea btw!

      Comment


      • #4
        If you select lift arc the ready light should come on, if you select lift arc remote remote then the ready light will not come on until you start whichever type of remote you have. At least thats what I remember, I had the torch mounted and the foot remote and never tried to work it any other way. The first models of the STL had only two lights as I recall, one for stick operation and one for tig operation and you needed to do something funny to get lift arc or remote lift arc. I couldn't find any manual for the earily version though, I think it was superceeded by the three light one shortly after they were interduced. I would call Miller's tig shop, they will tell you everything you need to know to get it going right.

        Comment


        • #5
          Sundown: mine only has 2 lights. i bought mine from some guy on craigslist.org. when he sold it to me it only included the stick package so maybe he kept the remote torch and regulator. i think it may still be stuck in remote mode. does anyone know the "funny" thing i have to do to get mine to work without the remote?

          thanks for the help so far!
          Last edited by campusperformance; 01-04-2007, 06:43 PM.

          Comment


          • #6
            If you go here and put in the units serial # that should get you the correct manual.

            Comment


            • #7
              Originally posted by campusperformance View Post
              Sundown: mine only has 2 lights. i bought mine from some guy on craigslist.org. when he sold it to me it only included the stick package so maybe he kept the remote torch and regulator. i think it may still be stuck in remote mode. does anyone know the "funny" thing i have to do to get mine to work without the remote?

              thanks for the help so far!
              Some were sold as stick only and did not include the remote. Matt's advice is right, using the serial number should get you the correct owners manual, if you don't have the serial number then you only get the latest manual.

              Comment


              • #8
                alright got the manual and figured it out. just for future reference what you do is press the selector button and hold it down while turning on the machine. that will enter setup mode. then you can choose the mode you want.

                thanks guys for all the help. i just started tig welding yesterday and im getting the hang of it.

                Comment

                Working...
                X
                Special Offers: See the latest Miller deals and promotions.