Announcement

Collapse
No announcement yet.

Restoration Of Aead 200LE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Restoration Of Aead 200LE

    Hey all, I've been given an awesome welder (been researching it on this site and others for a while now) and am interested in getting her fixed up, painted, and in service. The unit was free so I'm able to sink additional capital into it. I was hoping to benefit from the expertise on this forum to complete this project!
    Name:  684ca388322f32082bd0444eb1c2e733.jpg
Views: 1
Size:  53.8 KBName:  6d8cd8f626a42da0b71ee767d2b6c17d.jpg
Views: 1
Size:  44.8 KB
    Welder Info: Model Aead-200le
    Welder Serial: HG028167
    Onan: CCKA-MS/2748J
    Onan Serial: b760-102942

    So far I've added tires, and done everything necessary to get her purring like a kitten. I still need to purchase cables to test the welder but genset seems to be producing to spec using a multimeter (AC and DC).

    The issue: the governor shaft is broken flush to the top of the motor and all associated governor parts are missing. The carb linkage is intact but all adjustments have to be made by hand. I'm trying to locate pieces and parts but the governor parts aren't specifically listed in the miller manual, and there are several different types listed in the Onan manual.

    I'll post pics as I go, I've started with some ebay parts I'm hoping i can modify to work... but if someone had a working unit similar I could "copy" the dimensions and fab my own parts (with the exception of the governor shaft.)

    Thanks,
    --Kevin

  • #2
    I restored a 200le. needed some parts for gov. called and talked to a miller rep. got me all I needed. just have you mdl.# sr.# ready. will even tell you when it was made

    Comment


    • #3
      Will call Miller Tomorrow...

      Thanks, if that's the case this project just got a whole lot easier! Ill give miller a call in the morning and see where it gets me. Using the information on this form I was able to confirm it is an older 200le model made in 1976. I degeased the engine today and am starting to prep the body panels/trailer for paint... She's running great but the "tuna can" mufflers don't do too much for the noise! Do you have any suggestions for "cleaning" inside the generator? It has years of accumulated dust... Not really sure I should even bother. I've already cleaned the slip rings (wasn't initially producing electricity) but I'm hesitant to do anything more than blowing it out with compressed air.
      Last edited by Klong; 12-30-2011, 03:20 PM.

      Comment

      Working...
      X