Announcement

Collapse
No announcement yet.

Millermatic 200 and splatter

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Millermatic 200 and splatter

    I searched the forum for some info but didn't find what I was looking for.

    Anyway, I have this old Millermatic 200 that I have been using. I am getting a large amount of splatter. Initially, I thought it was normal until I used a friend's Millermatic 200. Welding the same piece with the same settings on his welder was completely different. There was almost no splatter. I also used a Lincoln (cant remember the model) and the splatter was minimal. Anyone have any clues? I am using .035 wire and welding .095 mild steel.

    Thanks
    Justin

  • #2
    Are you using the same shielding gas?
    Millermatic Passport Plus
    Millermatic 200

    Millermatic 350P with Python
    XMT 304 /w S-64 feeder and 12VS
    Dynasty 300 DX
    Thermal Arc 400 MST
    Victor O/A
    Premier Power Welder for my trail junk.

    Comment


    • #3
      Yes. Argomix 75/25

      Comment


      • #4
        Thats the right kind of gas maybe you got a bad bottle of gas try changeing it

        Comment


        • #5
          Do you have your polarity set correctly? It will spit and splatter if the polarity is set backwards. I know, I forgot to change my innitially when I switched from fluxcore.

          Comment


          • #6
            Weld spatter

            Originally posted by sprbxr View Post
            I searched the forum for some info but didn't find what I was looking for.

            Anyway, I have this old Millermatic 200 that I have been using. I am getting a large amount of splatter. Initially, I thought it was normal until I used a friend's Millermatic 200. Welding the same piece with the same settings on his welder was completely different. There was almost no splatter. I also used a Lincoln (cant remember the model) and the splatter was minimal. Anyone have any clues? I am using .035 wire and welding .095 mild steel.

            Thanks
            Justin
            You might want to try switching guns from your friend's machine. Sometimes the liner can get plugged or even have splatter build up deep inside the nozzle of a gun. Make sure that the gun is pushed into the machine far enough so there isn't any gas leakage.

            Comment

            Working...
            X