Announcement

Collapse
No announcement yet.

OT reddy heater question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • OT reddy heater question

    I have readyheater 70.
    It is a 70,000 btu heater that runs on kerosene. It will shut down in about 5 minutes.
    I used the heater last year with no problems, actually thinking back, near the end of the cold season it would shut down.
    I bypassed the thermostat tonight but it still shuts down.
    I use the wood stove but the heater is quick heat.
    I know this has nothing to do with welding, but I am sure I am not the only one to heat the shop in this manner.
    Any help is appreciated.
    Thanks.
    Tim Beeker,
    T-N-J Industries
    (my side bussiness)

    Miller Synchrowave 350LX with tigrunner
    Esab 450i with wire feeder
    HH135 mig
    Thermal Dynamics cutmaster 51 plasma cutter
    Miller aircrafter 330 - sold
    Marathon 315mm coldsaw
    vertical and horizontal band saws
    table saw
    Dewalt cut off saw
    Sand blast cabinet
    lots of hand grinders
    Harris torch
    beer fridge

  • #2
    dose it have an oxygen sensor ?? i would suspect one of the safety shut off options is doing it. have you tried blowing it out with air to clean stuff up?? i don't know, just guessing here as i have a propane one, but blowing it out solved a similar problem on mine.
    thanks for the help
    ......or..........
    hope i helped
    sigpic
    feel free to shoot me an e-mail direct i have time to chat. james@newyorkmetalart.com
    summer is here, plant a tree. if you don't have space or time to plant one sponsor some one else to plant one for you. a tree is an investment in our planet, help it out.
    JAMES

    Comment


    • #3
      does it have an oxygen sensor????????
      Nick
      Miller 252 Mig
      Miller Cricket XL
      Millermatic 150 Mig
      Miller Syncrowave 200 Tig
      2-O/A outfits
      Jet Lathe and Mill
      Jet 7x12 horz/vert band saw
      DeWalt Multi Cutter metal saw
      Century 50 Amp Plasma Cutter
      20 ton electric/hydraulic vertical press
      Propane Forge
      60" X 60" router/plasma table

      www.youtube.com/watch?v=jTu7wicVCmQ
      Vist my site: www.nixstuff.com
      and check out some of my ironwork and other stuff

      Comment


      • #4
        I did take cover off of it and blow it out good. It was not too dirty. It does have a sensor, thought it may be a thermal couple but it is short and larger in diameter. It may be an O2 sensor.
        How would I check it?
        Thanks for the response, I was not sure anyone would respond since it is not welding related.
        Tim Beeker,
        T-N-J Industries
        (my side bussiness)

        Miller Synchrowave 350LX with tigrunner
        Esab 450i with wire feeder
        HH135 mig
        Thermal Dynamics cutmaster 51 plasma cutter
        Miller aircrafter 330 - sold
        Marathon 315mm coldsaw
        vertical and horizontal band saws
        table saw
        Dewalt cut off saw
        Sand blast cabinet
        lots of hand grinders
        Harris torch
        beer fridge

        Comment


        • #5
          I use on at work and it wouldn't even light up when I first tried it....I drained the fuel tank and put a gal of fresh fuel in it and it fired right up and has done just fine...I even poured in some used / excess oil in it and it is doing just fine...I know it's not the exact same problem you are having , but it could be trash getting sucked up and blocking the fuel then after it shuts down the trash drops back into the tank....
          Mike
          George W. Bush was saving your butt whether you liked it or not!
          Fear is temporary, regret is forever
          HH210 with SG

          Comment


          • #6
            A lot of them also have a sensor that detects the flame (photocell??). When the lens gets dirty it will not "see" the flame and shut down the heater just as you described.

            Comment


            • #7
              I'm assuming the style heater you are talking about is a "jet engine" style for lack of better description. The reason I ask is that I have some older wick style fuel oil heaters, but they aren't that big. Anyway...... My dad has an old Master heater that had a similar problem years ago. The way it was designed, there was vane style air pump that was driven off of the back shaft from the blower. The pump was used to deliver the fuel to the burner by means of a sphioning action of the air flow over a tube from the fuel tank. Much like a non-HVLP paint spray works. We had various trouble with that. Sometimes the air filter would clog up, or trash would get in the fuel spout. Eventually the vanes wore into the pump housing and would give erratic air flow. Sometimes it would run just fine and then "click" just shut off.

              Just in reading what you have described about the problem, I would look at electrical connections and so forth. Since it is actually firing up and running for a little bit, it sounds like there is some thermal expansion going on and a connection is failing. Once it cools back off, then it reconnects and runs again. They usually have a constant spark ignition system as well with an igniter that works like a big spark plug. Might check all those connections and see if something is loose. I would also double check your fuel and maybe drain and refill it. One of the bad thing about seasonal equipment is water contamination. If you store it with a less than full tank, you can get condensation problems. If the temperature a/o humidity levels change drastically it can "rain" inside your fuel tank. Just like the inside of a non-insulated metal building. I'm not sure about Kerosene, but from what I've been hearing on the ULS Diesel fronts is that that stuff is way more hydroscopic than the old LS Diesel was. If this happens, then the condensation will be more readily absorbed into the fuel which promotes mossing and we all know how fun fuel system are to clean out. Just some food (or in this case fuel) for thought.

              Random note.....I had some scented lamp oil for the old coal oil style lamps that I dumped into one. Gave the heat a nice "lemony" smell (on top of the CO2, because no one ever runs one of those heaters in an enclosed, non-vented environment.....yeah).

              SSS
              Last edited by SkidSteerSteve; 01-03-2008, 08:50 PM.
              Bobcat 250, MM 210, Syncrowave 180, Spectrum 375
              Cat 242B Skid Steer, Challenger (Cat/Agco) MT275
              1 Thessalonians 4:11-12

              Comment


              • #8
                update

                I tore into it again this evening, Took the cover off it and started it up. Ran fine for a few min. then died. I noticed the fuel "spit" right before it died. Restarted, adjusted the two scews on the rear (not sure what the do,think 1 is for fuel flow) and now stays running.
                Heating good, no extra fuel smell, seems to be OK.

                Thanks to everyone that responded, I tried the suggestions, I knew the people here would help another out.

                THANKS to all.
                Tim Beeker,
                T-N-J Industries
                (my side bussiness)

                Miller Synchrowave 350LX with tigrunner
                Esab 450i with wire feeder
                HH135 mig
                Thermal Dynamics cutmaster 51 plasma cutter
                Miller aircrafter 330 - sold
                Marathon 315mm coldsaw
                vertical and horizontal band saws
                table saw
                Dewalt cut off saw
                Sand blast cabinet
                lots of hand grinders
                Harris torch
                beer fridge

                Comment

                Working...
                X