Announcement

Collapse
No announcement yet.

Elite Welding Hood

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Elite Welding Hood

    I have been having an Elite Hood for a few years know i like it a lot. I have started having problems with it. I was woundering if anyone could help me diagnoise the problem. My local supply house was no help. At power on, it blinks twice as it is susposed to then it goes dark and stays dark. Tried adjusting darkness setting, changing new batterys it still does it. Can anyone help!!!!!

    Taw Paw

  • #2
    Did you try turning the sensitivity down a bit?

    Comment


    • #3
      i have the same hood, and a little bit back, i had the same problem. i took it in to the local miller dist. and they changes the lens for me, under warranty. i had the hood for less than one year.
      welder_one

      nothing fancy, just a few hot glue guns for metal
      www.sicfabrications.com

      Comment


      • #4
        My Elite will do this on occasion, usually I just push the power button and it works poperly after.? Like TS-Off-Road said, try turning down your sensitivity. I know if I turn mine up to much it stays dark, and then turns off after its 15-20 minute period, leaving you blinded.
        Your not working outside in the sun by any chance are you?
        Dynasty 200DX, first generation
        Makita 5" grinder
        Makita 14" abrasive saw
        IR SS5L compressor
        Whole bunch of hand/air tools.
        and a wish list a mile long

        Comment


        • #5
          Originally posted by TS-Off-Road View Post
          Did you try turning the sensitivity down a bit?
          I turned the sencor both ways no difference. I also tried blowing it out with air compressor. What do you thing about takeing the sensitivity knob off and checking out under it?

          Comment


          • #6
            Originally posted by shorerider16 View Post
            My Elite will do this on occasion, usually I just push the power button and it works poperly after.? Like TS-Off-Road said, try turning down your sensitivity. I know if I turn mine up to much it stays dark, and then turns off after its 15-20 minute period, leaving you blinded.
            Your not working outside in the sun by any chance are you?
            No i am in a shop. The darn thing worked GREAT for a few years and then it started acting up. I am interested in knowing what is wrong, I am a freak like that. The dealer wants me to purchase a new one I want to know what is wrong first.

            Comment


            • #7
              Originally posted by Taw Paw View Post
              The dealer wants me to purchase a new one I want to know what is wrong first.
              Sounds like the dealer wants money to me. Mabye try a differnent dealer/ shop.
              Dynasty 200DX, first generation
              Makita 5" grinder
              Makita 14" abrasive saw
              IR SS5L compressor
              Whole bunch of hand/air tools.
              and a wish list a mile long

              Comment


              • #8
                I've not had such a problem w/my BWE, but I'd check w/Miller, might be something they could do or suggest doing.
                Good luck
                L*S

                Comment

                Working...
                X