Announcement

Collapse
No announcement yet.

IR Compressor Mounted

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    I will also mention, five years ago I bought two Champion air compressors, one for me and one for a customer, with the same Kohler engines. ANYTIME, we started these things, took multiple starts to get them running. Turns out it was connected to the oil pressure shutdown, for whatever reason, bad switch, too long to build up pressure, I don't know. The sensor is right next to the oil filter, just unplug a wire. Starts first time, every time now. I would assume, and hope, Kohler has fixed this problem since.
    Obviously, I'm just a hack-artist, you shouldn't be listening to anything I say .....

    Comment


    • #32
      Originally posted by JSFAB View Post
      I will also mention, five years ago I bought two Champion air compressors, one for me and one for a customer, with the same Kohler engines. ANYTIME, we started these things, took multiple starts to get them running. Turns out it was connected to the oil pressure shutdown, for whatever reason, bad switch, too long to build up pressure, I don't know. The sensor is right next to the oil filter, just unplug a wire. Starts first time, every time now. I would assume, and hope, Kohler has fixed this problem since.
      I haven't experienced that at all. I'll screw around with it this weekend and report back any abnormalities.....

      Thanks
      Big 40 Deluxe
      12RC
      WC-24
      30A

      Dynasty 700

      XMT 456
      Custom Cart w/the following:
      S-74DX
      Optima Pulser
      Coolmate 3
      XR Control Box
      XR Alumna Pro Python W/C

      CP 302 w/22A
      MM210
      Synchrowave 180 SD

      Spectrum 2050

      TB 302
      12RC
      WC-24
      30A
      HF 251 D1

      Dynasty 200 Coming Soon

      Comment


      • #33
        Haz-Mat decals

        If you are posting that you are carrying haz-mat it MUST be on all 4 sides of the vehical. The DOT boys frown on not having the stickers all there. You should call your local HYway patrol and find out if ou even need them on a welding trailer.

        JIM

        Comment


        • #34
          Originally posted by jeepnjim View Post
          If you are posting that you are carrying haz-mat it MUST be on all 4 sides of the vehical. The DOT boys frown on not having the stickers all there. You should call your local HYway patrol and find out if ou even need them on a welding trailer.

          JIM
          Thanks for the tip.

          The reasoning behind that was just to satisfy the safety department where I work. Those stickers and the placement satisfied them for our welding rig on base, and my trailer as well.
          Big 40 Deluxe
          12RC
          WC-24
          30A

          Dynasty 700

          XMT 456
          Custom Cart w/the following:
          S-74DX
          Optima Pulser
          Coolmate 3
          XR Control Box
          XR Alumna Pro Python W/C

          CP 302 w/22A
          MM210
          Synchrowave 180 SD

          Spectrum 2050

          TB 302
          12RC
          WC-24
          30A
          HF 251 D1

          Dynasty 200 Coming Soon

          Comment


          • #35
            For 2.1 (Flammable) and or 2.2 (Nonflammable) Material the total weight of bottles and content under 1,001 pounds does not require placards. I don't understand requiring them on one side though, should be all sides or none at all. Nice looking rig.
            The democracy will cease to exist when you take away from those who are willing to work and give to those who would not. Thomas Jefferson

            Comment


            • #36
              Serviced mine today

              Originally posted by JSFAB View Post
              I will also mention, five years ago I bought two Champion air compressors, one for me and one for a customer, with the same Kohler engines. ANYTIME, we started these things, took multiple starts to get them running. Turns out it was connected to the oil pressure shutdown, for whatever reason, bad switch, too long to build up pressure, I don't know. The sensor is right next to the oil filter, just unplug a wire. Starts first time, every time now. I would assume, and hope, Kohler has fixed this problem since.
              I have that sensor on mine.I was changing the oil and filter today on my unit.Also fabbing a new engine pipe mine rotted out its 11 years old.I also modified the stock muffler to quiet these things down they make a **** of alot of noise.I,ll post a few pics when i,m done with the pipe.
              BB402D
              TB300D
              DIMENSION652
              MM250X
              MAXSTAR140
              S-32 FEEDER W/1260 IRONMATE FC/GUN
              HT/PWR-MAX1250 PLASMA

              Comment


              • #37
                Very nice rig!
                Bet you built the trailer eh? Nice!
                Grip treads for traction ?

                Comment

                Working...
                X