Announcement

Collapse
No announcement yet.

problem with shopmaster 300

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with shopmaster 300

    Hi I am hoping you guys can help me out I have a shopmaster 300 serial# kd519887 with a hf 251d-1 and a coolmate 4 cooler. the problem started when you would release the pedal the tig torch was staying energized so i tried a different pedal but had the same problem now I have no power coming out of the machine at the terminals when you hit the pedal cr1 relay activates and you get gas out of the torch but nothing else I tried regapping the tungsten in the back of the hf box but that did not help. I disconnected the hf box and tried stick welding still nothing the outlet on the front of the unit does have 120v if that matters
    Last edited by rollinheavy; 12-13-2017, 10:28 AM.

  • #2
    How old is the HF box? When you turn the SM300 on, can you hear the transformer humming?

    Power-off, a quick look under the covers might tell you something.

    Comment


    • #3
      Il have to check for a date on the hf box it looks fairly new however i did disconnect it and tried stick welding but still no power.i cant hear the transformer running because of the fan comes on

      Comment


      • #4
        2 things to check. TP1 circuit may be open. Shuts off the weld but allows everything else to function. Easiest and least expensive fix.
        PC1 is bad. More likely PC1 as you started having problems before it completely stopped welding.

        Comment


        • #5
          Thanks 1997cst I will check that out thank u

          Comment


          • #6
            Another thing to look at is the micro switches on the process selector, had one come loose during transport...
            Shopmaster 300
            Hf 251 PC300 Wp-17 torch
            S22p
            Airco wasp IIIe
            Aead 200le blue charge
            Spectrum 3080 50 foot torch

            Comment

            Working...
            X