Announcement

Collapse
No announcement yet.

Hobart beta mig "no weld" issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hobart beta mig "no weld" issue

    Recently acquired an older beta mig 250 and the fan comes on, wire feeder works but it won't strike an arc. Any input would be appreciated.

  • #2
    Manual is available here if you don't have one:

    https://data2.manualslib.com/pdf3/53...5e&take=binary

    I would want an oscilloscope to troubleshoot that machine. First thing I would do is scope the gate pulses on the SCRs (which are the "diodes" in that machine) and see if they are being told to turn on by the main circuit board--kind of splits the problem in half. You can probably find replacement SCRs if they're bad. If it's the circuit board, it may be difficult to find one. No diagram for it in the book.

    You could see see if you are getting DC voltage between the output studs and then between wires 33 and 34, which would eliminate a bad reactor. But that is not likely to be the problem. just do a thorough look-see inside for anything that looks to be loose, corroded, or overheated. You may get lucky.

    Comment


    • #3
      Would the main circuit board be the contactor? Is there any way to test the diodes other way than a diode tester on a multimeter? I don't see anything out of place but I will keep looking around the machine.

      Comment


      • #4
        This welder does not have a "main contactor" in the classic sense. Contactors are electromechanical switches that (directly or indirectly) turn on the weld output when you pull the trigger. Your trigger circuit is OK because the wire feeder is running.

        In place of a main contactor, the Betamig uses a pair of Silicon Controlled Rectifiers that are turned on alternately every 16.7 milliseconds (each cycle of the 60 hz power line) by the main circuit board feeding them appropriately timed gate pulses, as long as the trigger is pulled. They not only perform as diodes to rectify the AC line into DC, and act as electronic "contactors" to turn on the output power, but also control weld current by the amount of time they remain on every time they "fire". That "on time" is also controlled by the main board. For low weld currents, they turn on late in the cycle; for higher currents they turn on earlier. SCRs can be tested with a multimeter but it is not as simple as testing a diode-you can't just connect the leads two ways and know if they're good like you can a diode. There are procedures on the web for testing them.

        Hope this explains why the quickest way to troubleshoot this circuit design is to scope the gate pulses. That will immediately give you a direction to head for further troubleshooting.

        There may be some professional welder techs who have some simpler approach but this is how I would approach it.

        Comment


        • #5
          Does your welder look like the left or the right machine?

          Comment


          • #6
            It it like the one on the left except it does not have the controls on top left side.

            Comment


            • #7
              It is like the one on the left minus the option control panel on top left side

              Comment


              • #8
                stock number (7189-1 through 7190-2) maybe......... 200/230 unit or 230/480/575 unit

                Comment


                • #9
                  If my memory serves me right, I had the same problems with mine, look at the aluminum strap going up to the terminals inside the wire feeder side.
                  mine just burnt in two pieces. Simple fix, also the hi lo switch can go bad. Solid old machine, bet I have run 8 to 900 rolls of wire through it in 24 yrs

                  Comment


                  • #10
                    It is 7189-001

                    Comment


                    • #11
                      I have the wiring diagram if you need it. What kind of diode meter reading from work clamp to motor drive housing?
                      Is the K1 contactor pulling in, the one on the back panel, when trigger pulled? Per troubleshooting guide it suggest it could be the culprit, either coil or contacts bad.

                      Comment


                      • #12
                        I ended up taking it to a repair guy due to lack of time and patience. He was leaning toward the contactor.

                        Comment


                        • #13
                          Any news on what was wrong?

                          Comment

                          Working...
                          X