Announcement

Collapse
No announcement yet.

Dynasty 350 start curcuit won't work, please help!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynasty 350 start curcuit won't work, please help!!

    My Dynasty 350, ser # LH380556L, has a high freq. problem. Basically, the start circuit quit, both AC and DC. The lift arc mode will get it going, but the normal start mode acts like the lift arc. No way it will start an arc without contacting the tungsten to the ground. I cleaned and adjusted the points, but they were good enough before I touched them. We just replaced the power board a few months ago. Any thoughts on fixing it? Thanks, Kaase

  • #2
    usually the fuse pops on the aux power board, thats an easy one,never the less, your problem is with pc7 hf board

    Comment


    • #3
      Would I be safe to buy a new board? The only fuse I could find was a .1 amp, appears ok. Is there a relay or anything that makes noise in the welder when the foot pedal is depressed? Other than the gas starting up, it is silent when the pedal goes down.
      It says it has 345 hours on it. Is that a lot? Kaase

      Comment


      • #4

        no I'm saying that pc7 is pooched and you need a replacement

        Comment


        • #5
          Well, I replaced the PC7 board and nothing changed. The only fuse I can find on the power board checks good. Any more ideas?

          Comment


          • #6
            Is there sparks at the points?

            Comment

            Working...
            X