Announcement

Collapse
No announcement yet.

Trail blazer 302

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trail blazer 302

    Hello folks I need help again.. I have a T B 302 serial number MC170806R

    that will not arc " intermittently " had it in L W S 4 times they replaced brushes no help then once they replaced a board and it has worked fine for about 3 months = 20 hours this morning did it again tried to get an arc right at the ground clamp and you see sparks like if you ran a 12 V wire on bare metal maybe even weaker than that then turned of welder and it worked fine so far it has for about 45 minutes please help.... Thanks

  • #2
    Has it been raining in your area, cause thats what the problem sounds like, cap board is wet, or has a loose connection

    Comment


    • #3
      Tb 302

      No sir kept indoors ran fine for 2 hours then nothing but a faint spark like a 12 volt wire that has no ground then turned it off then back on and it started welding fine like I said its intermittent this happened 3 months ago the last time L W S replaced some board it ran fine till now

      Comment


      • #4
        They would have replaced the power board, however, I don't think thats the problem, I believe its with the connection plug between the the engine and generator system. Firewall left side. I believe its corroded. If you unplug it and replug it, that should reseat the pins. Dielectric grease works wonders at this point. I'd be doing this real soon, before the power board gets nuked

        Comment

        Working...
        X