Announcement

Collapse
No announcement yet.

xmt 304 problems / repair help needed.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • xmt 304 problems / repair help needed.

    I have a couple miller machines and love them. they are a millermatic 185 with a spool gun and a maxstar 200. so with that in mind i bought a xmt304 at an auction. i assumed it was broke and got it cheap so that is good. the bad part is what i found when i pulled the cover. i would like to repair it possible and affordable otherwise i will just part the good parts out and scrap the rest. if anyone can give me some pointers i would be greatfull.

    I have a fluke 87 meter and work at a powr plant so i may have better test equipment if needed.

    anyway here are the pics. what do i need to test first? and what typically causes this kind of damage?

    would the IGBT's be damaged from this?

    I dont have a tech manual yet and hate to buy one if this is a paper weight.

    thanks
    chris
    Attached Files

  • #2
    One of the contactors didn't switch fast enough. This what you will start with:

    Contactor Kit
    Power board


    Check input bridge and IGBT. Take the power board out and visually check
    the IGBT's again. With the power board out visually check the caps. Check the with a meter too.

    If the input bridge is bad replace the power switch.

    Comment


    • #3
      Complete waste of time, scrap it for parts, front display board should be safe from a massive surge and worth a few bucks!, and be done with it. If those contactors didn't switch fast enough or was put in the wrong power (more likely) then its garbage and no amout of money will fix it. This info comes from repairing thousands of units

      Comment

      Working...
      X