Announcement

Collapse
No announcement yet.

How to setup a suitcase x-treme 12vs to a big blue 300 pro and a big 40????

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to setup a suitcase x-treme 12vs to a big blue 300 pro and a big 40????

    We're using suitcase x-treme 12vs's on a big blue 300 pro and a big 40 at work. When we hook up the suitcase's to each welder we set the welder a to cv but if we switch the suitcase over to cv they weld horrible we are using .045 dual shield. It seems to weld ok with the suitcase's on cc and the welders on cv. If we put the suitcase's on cc and the welders on cc all you can do is spray arc. This doesn't make any sense to me. Can somebody please inform me on what were doing wrong?
    Thanks

  • #2
    Do you have a 14 pin cable hook up on your feeder, I don't think you do because its a VS feeder- Voltage sensing.

    I use RC feeders that require a 14 pin cable which allows it to weld like a shop machine which is what I think your trying to achieve.

    Comment


    • #3
      I took a second to get my book out and you have a Voltage sensing feeder, I have never actually used a VS feeder but I have been told they don't weld like a shop machine ( But keep in mind This is what I have heard )

      If you want a feeder to run just like a shop machine you want to get the 8RC or the 12RC, However doing so you will need to buy a 14 pin control chord.

      This is what I use on my trucks, I have my heavy power cable, 14 pin control chord and the gas hose taped together, I have ( 2 ) 75' cables so I can mig weld 150' from the truck.

      Something else that might be a problem is that you need to make sure your using the proper shielding gas if your using dual shield flux core.
      The stuff I use doesn't like the argon gas to be more than 75%.

      I also use all quick disconnect fittings so I can quickly disconnect my feeder from the cables.

      Comment


      • #4
        Is your polarity correct?

        Comment


        • #5
          Check your voltage sensing lead

          I had problems / teething issues when i was new to the 12VS and my TB302. Cable hooked to the CV terminal, and machine process selector to vs sensing feeder mode. That sensing lead has to have freshly ground bare metal to light up the meters and close the electric circuit good. Also open up the feeder and check the rocker switches. I found using using 045 mine had to be set to the CV setting, and the high speed selector. The high low switch can make a difference depending on what wire and gas selection specifically you are using. the parameters for each wire can be finicky to find the ideal settings.
          I have a welding addiction

          ...the only stupid question is the one you didn't ask

          Comment


          • #6
            Turn off soft start also

            Comment


            • #7
              New to using forums..... 12 VS help please

              Hi, I have a trailblazer 301g and I run a 12vs wire feeder. I have a couple issues..
              1- After doing a fair amount of welding with .045 dual shield my the electrode will not arc. Wire will still feed, welder idles up but no arc. After letting it sit for 5 mins it will work but only for a short time.

              2- When I set the voltage on the trailblazer between 24-27 volts, every time I pull the trigger and the machine idles up the screen on the feeder goes blank then comes back into it, almost like a quick reset...

              Any help would be greatly appreciated!

              Jason

              Comment


              • #8
                Really if you have no procedure, then yes dual shield works much better on CC, Procedure welds, you kinda screwed, and have to get used to it. Esab dual runs better in CV than a Liquidaire version.

                Comment

                Working...
                X