Announcement

Collapse
No announcement yet.

Trailblazer 250G runs but doesn't generate anything

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trailblazer 250G runs but doesn't generate anything

    Need a little assistance, I have a welder s/n KB145838 that doesn't generate much voltage. I tried flashing it at wires 17 &19 and didn't get and sustainable change. Fuses are good, I get .6 volts across wires 14&15 with unit running and 2 volts at outlet. Any ideas? Thanks

  • #2
    Have you checked your brush length or cleaned the slip rings ?

    Comment


    • #3
      Do you have what the tolerances should be, I ohmed them out and they seem ok. Also can you clarify for me, how does the exciter coil create the AC voltage. Is it through the rings and brushes? Thanks

      Comment


      • #4
        Didn't have much time to look up what year machine you have but read through this.
        http://www.millerwelds.com/resources...highlight=250G
        MM250
        Trailblazer 250g
        22a feeder
        Lincoln ac/dc 225
        Victor O/A
        MM200 black face
        Whitney 30 ton hydraulic punch
        Lown 1/8x 36" power roller
        Arco roto-phase model M
        Vectrax 7x12 band saw
        Miller spectrum 875
        30a spoolgun w/wc-24
        Syncrowave 250
        RCCS-14

        Comment


        • #5
          Another post with some info.

          http://www.millerwelds.com/resources...t=250G+exciter
          MM250
          Trailblazer 250g
          22a feeder
          Lincoln ac/dc 225
          Victor O/A
          MM200 black face
          Whitney 30 ton hydraulic punch
          Lown 1/8x 36" power roller
          Arco roto-phase model M
          Vectrax 7x12 band saw
          Miller spectrum 875
          30a spoolgun w/wc-24
          Syncrowave 250
          RCCS-14

          Comment


          • #6
            Manually exciting it probably was stupid, as the unit has an exciter board. You likely took out a diode in the line. Since your f1 fuse was ok, the brige it protects is ok. Your exciter board is the likely culprit and the the diode inline with wire #18 is now poofed.

            Comment


            • #7
              Thanks for info fellas. Cruzier, this unit has only one board and it's called the Field Current Regulator Board. Is that the same thing as the exciter board?

              Comment


              • #8
                I meant Cruizer

                Comment


                • #9
                  You want to check for resistance between wires #28 and #15. pull these wires of bridge SR3. If you get less than 5 ohms, this circuit is happy, if not then this circuit is toast, and there is nothing you can do about it. Generator is trash.

                  If it measures well, brushes are good, clean the the slip rings with a fine emery cloth splashed with brake cleen. If this all fails then yes its that regulator board

                  Comment


                  • #10
                    Cruizer, wires 15 & 28 ohmed at .4 ohms between them disconnect from the SR3. We swapped the board out with a good one from our other 250g trailblazers as one of the first things that we tried and got the same results. I'll try to clean the rings and take a another look at the brushes . Thanks again.

                    Comment


                    • #11
                      State - there's a bunch of other checks you need to make to identify the cause. PM me an email address.
                      MM200 w/spot controller and Spoolmatic 1
                      Syncrowave 180 SD
                      Bobcat 225G Plus LPG/NG w/14-pin*
                      *Homemade Suitcase Wire Feeder
                      *HF-251D-1
                      *WC-1S & Spoolmatic 1
                      PakMaster 100XL
                      Marquette "Star Jet" 21-110

                      Comment


                      • #12
                        PM received and email sent.
                        MM200 w/spot controller and Spoolmatic 1
                        Syncrowave 180 SD
                        Bobcat 225G Plus LPG/NG w/14-pin*
                        *Homemade Suitcase Wire Feeder
                        *HF-251D-1
                        *WC-1S & Spoolmatic 1
                        PakMaster 100XL
                        Marquette "Star Jet" 21-110

                        Comment

                        Working...
                        X