Announcement

Collapse
No announcement yet.

digital elite auto off issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • digital elite auto off issue

    I replaced the batteries in my digital elite a month ago LWS did it for me and the hood won't power up.

    I believe there may be an issue with the auto power off?

    I used the hood 3 times for about 1 hr since last batt change

    Any advice appreciated

  • #2
    Originally posted by ericher69 View Post
    I replaced the batteries in my digital elite a month ago LWS did it for me and the hood won't power up.

    I believe there may be an issue with the auto power off?

    I used the hood 3 times for about 1 hr since last batt change

    Any advice appreciated
    What brand of battery??

    there was an issue with intermittant contact on the battery holder with some brands...

    Panasonic are OK but Energizer have probs

    http://www.millerwelds.com/resources...001#post270001
    Last edited by H80N; 11-15-2013, 05:48 PM.
    .

    *******************************************
    The more you know, The better you know, How little you know

    “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

    Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

    My Blue Stuff:
    Dynasty 350DX Tigrunner
    Dynasty 200DX
    Millermatic 350P w/25ft Alumapro & 30A
    Millermatic 200

    TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

    Comment


    • #3
      digital elite auto off issue

      H80N,

      I am aware of the Energizer issue. I did check at the LWS and they did install Panasonic batteries.

      Maybe I'll take it apart and see if the batteries are still good.

      If so then the it may be the intermittent contact issue.

      If dead then something is malfunctioning

      Thank you for the prompt reply!

      Comment


      • #4
        digital elite auto off issue

        So I pulled both batteries tonight; result...

        1.31V and 1.71V

        Obviously the hood is not shutting off automatically.

        Any way to shut off manually?

        Comment


        • #5
          Did you try pushing and holding the reset button. That usually solves issues I've had.

          Comment


          • #6
            Originally posted by @cvmechanical View Post
            Did you try pushing and holding the reset button. That usually solves issues I've had.
            No.

            Will replace batteries again and try the reset before putting the hood away

            Comment


            • #7
              digital elite auto off issue

              I have had dig elite probs since day one. I bought a Jackson off a new guy in the shop who thought welding was fun in school but not practice. I had the mod replaced 3times because of the auto dark not engaging or batt dying every week.
              Syncrowave 250
              Millermatic 210
              dialarc 250
              spectrum 375x
              trailblazer 302
              Lincoln 135

              Comment


              • #8
                Originally posted by strictlycarved View Post
                I have had dig elite probs since day one. I bought a Jackson off a new guy in the shop who thought welding was fun in school but not practice. I had the mod replaced 3times because of the auto dark not engaging or batt dying every week.
                Bought a Miller Performance 5 years ago when I was in school. Still working great! Don't know anything about the new digitals. I just bought one of the new ESAB A/D hoods. Best hood I ever used!!! The colors are amazing! Imagine a hood that let's you see the puddle with your naked eye-without the side effects! Lol!

                Comment


                • #9
                  digital elite auto off issue

                  I believe I found the issue.

                  I need to hold the power button a few seconds to turn it off.

                  I will see if this solves the issue

                  Comment


                  • #10
                    been having my elit for well over 6 years now I replaced the batteries one time but I never ever power it off.when I'm done welding it hangs on the bottles or it gets thrown in my tool box

                    Comment


                    • #11
                      digital elite auto off issue

                      Appreciate the info.

                      Do you leave it in X mode when storing it or another mode?

                      I think there may be a electro-magnetic field causing it to stay on?

                      Comment


                      • #12
                        digital elite auto off issue

                        Was sending the unit in for warranty work for this issue but after keeping the shop at a 40 degree Fahrenheit minimum for over a week (it's -16 out) the hood has not powered up on its own and the batteries are fine.

                        Have not tried the auto off feature; how long till it powers down on its own?

                        Thanks

                        Comment

                        Working...
                        X