Announcement

Collapse
No announcement yet.

Having issues and can't figure out the problem need help.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Having issues and can't figure out the problem need help.

    My regency 250 power source or 22a 24 volt wire feeder is messing up. It sounds like the gas is being blown but there is no porosity.

  • #2
    Originally posted by trailerguy89 View Post
    My regency 250 power source or 22a 24 volt wire feeder is messing up. It sounds like the gas is being blown but there is no porosity.
    More details??

    Bead problems?? pics??
    .

    *******************************************
    The more you know, The better you know, How little you know

    “The bitterness of poor quality remains long after the sweetness of low price is forgotten”

    Buy the best tools you can afford.. Learn to use them to the best of your ability.. and take care of them...

    My Blue Stuff:
    Dynasty 350DX Tigrunner
    Dynasty 200DX
    Millermatic 350P w/25ft Alumapro & 30A
    Millermatic 200

    TONS of Non-Blue Equip, plus CNC Mill, Lathes & a Plasmacam w/ PowerMax-1000

    Comment


    • #3
      No pics right now but the bead is fine but it doesn't sound right when I am laying it almost like an argon surge or something I threw an old 250 up and plugged it in and it was great for a little bit but now its back to the same thing. And I can't turn the knob down to 5 or it doesn't work at all

      Comment

      Working...
      X