Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

The forum is currently undergoing maintenance and is in a 'read-only' mode for the time being. Sorry for the inconvenience.


  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Millermatic 210 wire feeding problem

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Millermatic 210 wire feeding problem

    Hi, I have a Millermatic 210 that I bought used off a friend about 6 yrs ago. I've used it on a few projects since I've had it, and it's always performed perfectly. Just this week it's started acting up. When I pull the trigger, I can hear the relay click but the wire doesn't feed out of the gun. I pulled the case off, and the drive rollers aren't turning. I checked to see if the motor was still plugged in, it is. I checked the trigger switch on the gun, it's good. If the welder is off, and I hold the trigger on, then turn the welder on, it drives for 2 seconds, then dies and won't turn unless the welder is switched off/on again. I jumped the motor wires with 24v, and it appears to work correctly (continuously turns). Any thoughts? Thanks.
Working...
X
Special Offers: See the latest Miller deals and promotions.