Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

225G Runs but no weld or generate

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 225G Runs but no weld or generate

    I have a Miller 225G, serial number KA903184. I was welding with it and stopped for lunch. When I returned it starts fine but will not weld or generate. Any ideas?

  • #2
    Do you have the op manual. There's a fuse under the cover it shows it in the manual. Won't weld or gen without it that's a good place to start.

    Comment


    • #3
      Thanks, I will look for the fuse. I don't have the OP manual. Is the fuse easy to recognize? I also might mention that a couple of weeks before it quit welding, the charging system on the engine stopped charging the battery and I had to put a battery charger on it to keep the battery charged. Would that be relevant?

      Comment


      • #4
        Maybe some of the experts can weigh in I don't know about the battery charger. I had to order a voltage regulator for the one I used to have there not to high. Look on the site here I believe its resources put your serial number or model name in the manuals are free. On the fuses just pull your top cover you'll see two fuses in a block could be bad connection or blown fuse I believe 20 or 25 amp 250 volt . There's also a a small flat fuse inline in the wiring back towards the engine end. It shows all the fuses in the manual if you can't find the manual post your model and serial number and I will post the URL for the manual.

        Comment


        • #5
          you've got 2 fuses under the top cover, check em.

          Comment


          • #6
            I found the D4 Diode in the ignition circuit next to the F2 Fuse to be bad. Can anyone tell me what size diode or part number or whatever to ask for at a electrical supply? The Miller agent here doesn't have them. The F2 fuse blows instantly whenever the engine is started. Would this cause my run but no weld or charge problem?

            Comment


            • #7
              6 amp 600 volt (from parts list) However if that is blown, your control bridge is likely the culprit. so get yourself that diode and a 35 amp 800 volt control bridge. All in all around the $30 mark for both.

              Comment


              • #8
                Couldnt find the control bridge on the list. Is it called something else? Or does anyone know the part number for the control bridge?

                Comment


                • #9
                  I don't buy these from miller as a simple bridge costs me $6, a diode. free.

                  Comment


                  • #10
                    Originally posted by rhtrigger View Post
                    Couldnt find the control bridge on the list. Is it called something else? Or does anyone know the part number for the control bridge?
                    Technically it's called a "full wave bridge rectifier" and referred to as SR2 in the electrically schematics and parts list. Miller part# 035 704, rated for 40A/800V.

                    That 6A/600V diode D4 is Miller part# 117 566.

                    Both items can be had for $20-25 thru Miller dealers or less at local/online electronics outlets.

                    Comment

                    Working...
                    X
                    Special Offers: See the latest Miller deals and promotions.