Announcement

Collapse
No announcement yet.

cruizer help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • cruizer help

    Took my Trailblaer 325 in with 49 hours because it was acting erratically and flashing things on the screen. Picked it up Saturday and headed back up to work. Now here we are Tuesday and this piece of **** is acting up again. Screen is flashing again and says TMPI open across the screen. Maybe it's time I took it back and traded it for a Ranger 305...

  • #2
    Were you running it hard cause thats a temp issue.

    Comment


    • #3
      cruizer help

      Running a grinder at excel power

      Comment


      • #4
        That explains the inverter high heat. Excell is handy, for other stuff, not so much for grinding. Most inverters and thats all it is, don't care much for grinders. Lets avoid Excell. The unit should work fine, if you just let it the inverter cool down, then turn it off and restart it.

        Comment


        • #5
          cruizer help

          Appreciate the help ! I'll give that a try tonight

          Comment


          • #6
            Well, does the unit work ok??

            Comment


            • #7
              cruizer help

              No still glitching. Ran it for 10 minutes this morning and it was ok

              Comment


              • #8
                Soooo, are you going to use it or are ya going to switch it out.....

                Comment

                Working...
                X