No announcement yet.

330 AB/P Foot pedal

  • Filter
  • Time
  • Show
Clear All
new posts

  • 330 AB/P Foot pedal

    I have a 330 AB/P and all of the sudden the foot pedal doesn't control amps its all or nothing as soon as you press the pedal if you try to set amps lower it doesn't want to start. Any Ideas or troubleshooting help. The foot pedal is a RFC-23A.

  • #2
    Seems like there is a broken wire to the rheostat.
    From your description, your switch still works.

    This remote uses what I call "toasters" as the current control.
    This is a high power or wattage ceramic element so the newer potentiometer based remotes will not work as a substitute.

    My suggestion is to open the case and check wire continuity and connections visually first and then with an ohmmeter.
    Also check continuity from the remote connections to the connectors.

    Good luck
    Miller Dynasty 350, Dynasty 210 DX, Hypertherm 1000, Thermal Arc GTSW400, Airco Heliwelder II, oxy-fuel setup, metal cutting bandsaw, air compressor, drill press, etc.

    Call me the "Clouseau" of welding !


    • #3
      Many times the wires in the cord exiting the pedal fray and break. Check continuity there too.
      Nothing welded, Nothing gained

      Miller Dynasty700DX
      3 ea. Miller Dynasty350DX
      Miller Dynasty200DX
      ThermalArc 400 GTSW
      MillerMatic200 with spoolgun
      Lincoln SP-170T
      Linde UCC305 (sold 2011)
      Hypertherm 1250
      Hypertherm 800
      PlasmaCam CNC cutter
      Fadal Toolroom CNC Mill
      SiberHegner CNC Mill
      2 ea. Bridgeport
      LeBlond 15" Lathe
      Haberle 18" Cold Saw
      Doringer 14" Cold Saw
      6 foot x 12 foot Mojave granite


      • #4
        This should give you guys a chuckle for the day

        Its fixed I didn't notice that the upper switch for the remote was bumped to the off position. I'm getting old I guess didn't see it until I unplugged the the foot pedal as the plug and cord hang over it thanks for the replies.