Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Spectrum 375 Xtreme Issues/troubleshooting

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spectrum 375 Xtreme Issues/troubleshooting

    I purchased a Spectrum 375 Xtreme used from a friend of mine. The original ICE torch was run over, and my LWS said the XT30 was an upgraded replacement, and the it was very easy to install. So I opened up the machine tonight and swaped over the torches. It was super straight forward, and I can't find anything I would have missed. I have the unit plugged into 220, and I have 100PSI going to it. The power light comes on, but when I pull the trigger nothing happens. No smoke, no crazy noises. There's no damage to the unit that I can see. According to my friend he used it very little. I'm stumped. Is there anything I should look at? Anything to check? Thanks guys.

  • #2
    I would contact the Miller Customer Service folks and talk to them directly (920-734-9821). I've called them before and they are first-class, helpful folks.

    Steve

    Comment

    Working...
    X
    Special Offers: See the latest Miller deals and promotions.