Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Cruizer- XMT 304 Problem

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cruizer- XMT 304 Problem

    i've had this baby for a few days and all i do is dream about it. my pal over in the weldingweb.com said 'cruizer could input

    any help greatly appreciated in finding the values for these little crispy critters! I beleive ive found the black resistor labeled R7 to be 200 ohm 20 watt. Plzzz, any ideas, info or values on the piece the red arrow is pointing at? He's labeled C6 . He got a little melted touching against blown R7
    Attached Files

  • #2
    Arrow is pointing at a cap ( blackened but likely still ok), the resistor itself is a 200 ohm 25 watt. Now in order for this to blow, that SR1 it was sitting on is roasted. So it took a major surge. I'd suggest you check the auxillary transformer. The round thing up and at the back of the machine. Also check the output board (right side vertical board) also houses the IGBT's

    Comment


    • #3
      If it took a big hit, you might want to check R250 on PC1 and make sure it's not toast. It's located toward the front of the board to the right of RC4.

      Comment


      • #4
        Hay Bella, I've got a dilema with another 304, unit has 52vdc Ocv, Everything tests fine, swapped out pc3 with my test board, pc1 is new, igbt's are new as well as, SR1. Unplugged the hall to no effect, Caps are charging to 288 Vdc (208 line)

        No error code.

        Comment


        • #5
          Is the 52v OCV showing on both your DVM across the output studs and the readout on the machine?

          Comment


          • #6
            Caps should be charging closer to 325vdc even with 208vac input but I don't see how that would make up for a loss of almost half of your OCV.

            Comment


            • #7
              Excuse me, caps should charge closer to 325vdc with 230vac input. Take and hook it up to a 460vac supply and see if it still comes up short on the output side.

              Comment


              • #8
                It's one of my toys, I'll get back later as I have to fix customer machines...

                Comment


                • #9
                  Originally posted by cruizer View Post
                  It's one of my toys, I'll get back later as I have to fix customer machines...
                  Cruiser,

                  Be sure output diodes are really OK. And you may have to flip it upside down and take the bottom off to get a good visual on the condition of the HF transformer. I have had one instance that the HF transformer was shorted winding-to-winding and caused the voltage value to be off.

                  I am assuming same OCV value was measured in both CC and CV.

                  Comment

                  Working...
                  X
                  Special Offers: See the latest Miller deals and promotions.