Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

The forum is currently undergoing maintenance and is in a 'read-only' mode for the time being. Sorry for the inconvenience.


  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Dynasty 200DX no amperage control.

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynasty 200DX no amperage control.

    I have no amperage control via foot or hand controllers. I've even used a known good miller foot control and no dice. Unit works fine when RMT2T Hold is selected but not when RMT STD is selected. I can start an arc with whatever max amp. dialed in but the amperage doesn't deviate from start amperage.

    Any ideas out there? Pedal is set up with pins A-E. Do I need one or more of the other pins to use a standard tig torch on this?

  • #2
    Dynasty 200DX no amperage control.

    Have you done a reset?

    Comment


    • #3
      Did the factory settings reset.

      Comment


      • #4
        Any ideas on where to start looking for the issue? Are there fuses inside that go to the remote? Also, is it normal for this welder to make rectifying noise, buzzing, when powered up and not welding?

        Comment


        • #5
          Have you ever welded with this machine before with a foot control?

          Also, the humming noise is normal.

          Comment


          • #6
            Honestly I don't remember. I think we have but it's been stored away for several years.

            Comment

            Working...
            X
            Special Offers: See the latest Miller deals and promotions.