Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

XMT-300 turns on but will not hold an arc to weld

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • XMT-300 turns on but will not hold an arc to weld

    Help i need some advice. My new old 300 turns on all relays kick in and you can see plenty of amperage when you try to weld. The problem is that after the starter arc the machine seems to lose power. the arc wont carry and there is no welding when stick welding. I haven't tried tig yet mainly because i don't know how and got this welder to learn how. Any info will help thank you

  • #2
    Serial#,?????

    Comment


    • #3
      serial # KB083929

      Here is the serial number it took me a minute to find it

      Comment


      • #4
        Thinking you have a failed Hall device, 156313. Or a bad connection on the circuit board. Might try removing and reinserting all the plugs on the PC1 main board.

        Comment

        Working...
        X
        Special Offers: See the latest Miller deals and promotions.