Announcement

Collapse
No announcement yet.

Ranger 305G

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ranger 305G

    I have a problem with my 305g. The arc is hot and unstable with spatter, the puddle won't wet out and if I turn the machine down it just sticks. the arc sounds peculiar.I have changed out all my cables and bypassed my roll ups cleaned all connections and it's still the same.new stinger and ground too. Any ideas on what to look for next? Maybe the board. This machine is a new machine with less than 50 hrs on it. PS I run 2/0 cable with 1/0 stinger whip.

  • #2
    If the machine is new you should be headed to the distributor you purchased it from for warranty coverage. Start poking around on it yourself and you may be risking an otherwise valid warranty claim being rejected.

    IMO.
    MM200 w/spot controller and Spoolmatic 1
    Syncrowave 180 SD
    Bobcat 225G Plus LPG/NG w/14-pin*
    *Homemade Suitcase Wire Feeder
    *HF-251D-1
    *WC-1S & Spoolmatic 1
    PakMaster 100XL
    Marquette "Star Jet" 21-110

    Comment


    • #3
      Originally posted by maharg View Post
      I have a problem with my 305g. The arc is hot and unstable with spatter, the puddle won't wet out and if I turn the machine down it just sticks. the arc sounds peculiar.I have changed out all my cables and bypassed my roll ups cleaned all connections and it's still the same.new stinger and ground too. Any ideas on what to look for next? Maybe the board. This machine is a new machine with less than 50 hrs on it. PS I run 2/0 cable with 1/0 stinger whip.
      Run in Pipemode pretty much all the time. The sound your hearing is the ultra fast switching of the internal igbts ( normal sound) On the dig side of things 0-+10 gives you a flatter weld, with 0 to -10 giving you a more higher focusted weld. Running wire gives you opposite results.

      I love the 305's....

      Comment

      Working...
      X