No announcement yet.

My ground cable is getting very hot

  • Filter
  • Time
  • Show
Clear All
new posts

  • My ground cable is getting very hot

    I have check all the pulgs and the are good an tight I have put on a c clamp on the ground cable but its still gets hot and not welding right any Ideas ?

  • #2
    Well a little more info will be needed to help,

    What machine, what process, amps ?

    Sounds like your cable connection at your ground clamp is dirty or corroded or even too light of a clamp or cable is too small for the amps you are you using?

    2007 Trailblazer 302G
    2004 Invision 354MP
    1999 60 series feeder
    2005 Maxstar 200DX
    2007 CST280
    1999 HF 251-1
    older Hobart hefty wire feeder
    Hyperthrem 600
    Maxstar 150S(such a cute welder)
    had and sold........
    2003 XMT 304CC/CV
    1947 Lincoln SA200G short hood
    1963 Lincoln SA200G
    1975 Lincoln SA200G(best machine ever had )
    1970's Lincoln SAE400G
    2 Maxstar's 200DX's
    1 Maxstar 200SD
    CST 280
    2 CST 250



    • #3
      Only is going to get hot, if....

      - The cable is too small for the current applied
      - Wrong ground clamp, ie, a non brass version
      - A connection is loose, whether it be a crappy bond to the material being welded
      on or a loose cable connector


      • #4
        Almost guaranteed that it is the cable connection to the ground clamp. Replace it with the brass version and you get a much better connection with the ball screw arrangement.


        • #5
          My ground cable is getting very hot

          Yep. I agree. Run my 350-p since last fall, just put off replacing cheap OEM clamp. Grabbed it couple weeks ago was hot as fire (all bolts tight)
          Replaced it with brass one. No Heat.
          Can't believe u pay that much for a welder & it comes with that cheap clamp.


          • #6
            My ground cable is getting very hot

            Solder the cable into the clamp.
            Shipyards do it,works great.It also helps keep the water out when welding in the rain.


            • #7
              Just my experience, but I have found the ball screw to be better than solder. Soldered connection, especially if they see a lot of temp change over time become high resistance connections. I have, over a period of time, cut off all my soldered connection due to failure. IMHO not a great way to go.


              • #8
                My very first thought when I read that your CABLE gets hot is that the cable is under sized for the amps it is having to carry. If all the connections are right/tight...then my second thought is....wait for it....the cable is too small!
                Don J
                Reno, NV

                Never pick a fight with an old guy. Old guys are too smart to fight and get hurt. They'll just kill you and get it over with.


                • #9
                  I would think the engineers who design these welders are smart enough to include a cable capable of handling the intended current.

                  My first thought would be something either wore out or became loose. I would not guess the cable isn't big enough. If it once worked but now doesn't, something changed. Short of the cable being damaged, I wouldn't expect a cable to change.

                  I could be wrong. That's just how I troubleshoot.
                  Lincoln Vantage 400
                  Trailblazer® 302 Air Pak™

                  Miller Dynasty® 350
                  Millermatic 350P Aluminum
                  Millermatic® 252
                  Syncrowave 351
                  Lincoln LN-25 Pro

                  Multimatic™ 200

                  XR-Aluma Pro Gun
                  Diversion™ 180

                  Spectrum® 625 X-TREME™

                  Thermal Dynamics® Cutmaster® 52
                  Victor Oxy/Acetylene Set


                  • #10
                    Feel up your cable, welding cable that is, especially close to the connector and the work clamp, You are looking for soft, limp areas. It can mean that the cable inside the insulation is breaking off likely due to many flexings in its life. Cut it off and make a new connection. Also check along the cable for any place where it may have been jammed, it can give the same result. Also most of the above and more info might be useful.


                    • #11
                      Before you can feel up your cable...dinner is a must. Flowers perhaps
                      Miller 252 Mig
                      Miller Cricket XL
                      Millermatic 150 Mig
                      Miller Syncrowave 200 Tig
                      2-O/A outfits
                      Jet Lathe and Mill
                      Jet 7x12 horz/vert band saw
                      DeWalt Multi Cutter metal saw
                      Century 50 Amp Plasma Cutter
                      20 ton electric/hydraulic vertical press
                      Propane Forge
                      60" X 60" router/plasma table

                      Vist my site:
                      and check out some of my ironwork and other stuff


                      • #12
                        Why not throw in a movie too? Ha,ha.