Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Dual Shield welding help!!

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dual Shield welding help!!

    I've ran Dual Sheild wire in my 12vs powered by a Trailblazer 302 and it ran great. I just bought an older Millermatic 251MP and it doesn't seem to like it much. I tried to set the wire on the machine as .045 Steel and .045 fluxcore and it just does not like it. Does anyone have any tips for me to get this working with this machine? Thanks....

  • #2
    Dual Shield welding help!!

    What shielding gas are u using?
    Was having some problems at lower settings but ran good at higher voltage ie. spray transfer.
    I switched from 75/25 gas to 85/15 and ran better all way around especially at lower settings. Just a thought. (using 350-p)

    Comment


    • #3
      Thats a 250MP, not a 251, and the problem is that the 250 doesn't have the wire speed to run dual shield. Mild steel is fine on it though.

      Comment


      • #4
        I'm using CO2...

        You are correct, 250MP. I did the unthinkable and downloaded Millers iPhone app for welding setting - It actually worked - I was running 145 ipm and I needed to be at 210-230. It works great now! Also - I took my machine up to it's highest ipm setting - 670 is where it stopped, I think I have enough! Thanks guys and sorry for the brain fart!

        Comment

        Working...
        X
        Special Offers: See the latest Miller deals and promotions.