Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.


Announcement Module
No announcement yet.

Dynasty 300DX stopped working .. again!

Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dynasty 300DX stopped working .. again!

    Hi Guys,

    I need your help again.

    I had a problem with my Dynasty 300DX about a year ago, it was working perfectly in DC until I tried to weld some aluminium in AC. It started acting up and a long story short, I sent it overseas to get it repaired since there is no Miller tech centre where I live (MALTA , Europe ) , they changed the IGBTs and got it back working perfectly. I only did like 2 hours of welding ever since I got it back, now it stopped working again.

    I was welding some 304 stainless steel tubing, did about 4 inches of welding , stopped to turn the work piece. Went into position to start an arc on HF and pressed the pedal.... nothing happened !!! I was like what's wrong??? I checked ground, was ok, resharpened the tunsgsten, but still no arc. Checked all settings and all was ok. Then I had the idea of trying to start an arc on lift mode, but had no luck. Then I changed tungsten and tried on A/C and acted the same... no arc start which ever setting I tried. I also noticed that the high bzzz sound that makes when on HF start inside the machine, its not making it any more. Pre flow and post flow works ok.

    What I am noticing it doing is, when the pre flow time ends, it makes a click from the display area and the display says 0.6 and 500 and no arc happens. Then I lift off the pedal and post flow time starts ok and gas flows ok. On Lift arc, when I lift the tungsten, I hear the click but again, no arc. It looks like it lost all weld output and the HF noise that it used to make inside the machine has stopped aswell.

    Can you please help me out... I would appreciate it if maybe you guys could help me find out what's wrong. I have to spend money again to send the machine overseas for repair again. so if possibly there will be something I might check before I fork the money out again it would be great. Tech guy in his email said it could be an output diode but to be 100% certain he have to check the machine, which is 1500 miles away!!

    Your help will be greatly appreciated.

    Best regards,

  • #2
    Going to say that yor display board has a problem, since it runs the contactor circuit. The 0.6 volt kinda gives it away as being the problem. I'd guess though that when you put it in stick, voltage is present correct?


    • #3
      Thanks for your reply.

      The tech guy told me to use it in stick mode to see if its a power problem. But the thing is that when I bought it, it did not come with a stick electrode clamp. Should I buy one to start troubleshooting? If yes, can you please send me which brand I should get to get a good quality electrode clamp.

      So what the 0.6 and 500 stand for? HF start volts?

      Thanks again, your help is greatly appreciated.


      • #4
        Well in stick mode the display will come up to 83 volts. So you know its there.

        I'm quite certain the problem is with the display and nothing else.


        • #5
          I took a video with my mobile phone to show what the machine is doing. As you can see, I first tried HF start and then Lift arc start. You could hear the click the display makes, even when I lift the tungsten on Lift arc setting. I also pointed on which settings I am trying the machine on, I even changed the post flow and pre flow setting just so I can show that the gas function is working ok.

          Do you know a good seller from where I can find a display board?


          • #6
            Put the friggen thing in stick and turn the output on. What does the gage show for volts!

            Also, it may just be that the front membrane is sticking, Rub some armorall into it


            • #7
              Hi cruiser,

              Sorry for the late reply but been very busy with work lately.

              Ok did what you told me to do. Put the machine on stick mode, set the amps to 150 and pressed the pedal. The dispay showed 0.7 & 500


              • #8
                Don't put the machine in remote, ie, no pedal.


                • #9
                  Same Machine ,same trouble

                  Let me start by letting you know I am a welding teacher in N.J. With 30+ years experience in the field, I also have my own welding business.
                  Last night at school one of my students was using the Dynasty 300 DX that had been working fine in all modes for the past 1.5 years. The machine just stoped producing an arc while welding some stainless, no high frec. either.we have gas flow. I switched it to stick mode and it welded fine,went back tig mode and got squat. After checking all settings and the torch itself and hitting the reset button still nothing. So beeing out of options I set the memory module switch to 2 and the tig function again worked fine. I also tested modules 3 and 4 with no problems. I dug out the manual and found the sequence for resetting the factory defaults. All modules accepted the reset but not number 1. I believe module 1 is cooked !!
                  My question is this (can I change out a module)


                  Special Offers: See the latest Miller deals and promotions.