Announcement

Collapse
No announcement yet.

Miller 330A/BP welder (NO WELD OUTPUT)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Miller 330A/BP welder (NO WELD OUTPUT)

    Hello All, Here is the problem that I have and what I have done some far to trouble shoot it.

    I have a Miller 330 A/BP Gold Star welder. Not sure of the year it was made. I tried trouble shooting it using the owner manual. I have no weld output. The welder starts up just like normal. The fan motors running, when you hit the manual foot control the switch for the argon output kicks on and the water cooled torch starts flowing water out the water discharge hose, but i get no spark out the torch tip. I have checked the F4 10 amp 125 volt fuse and it checks good. I have switch the CB1 primary overload circuit breaker switch on and off and tried to weld in both positions nothing happens. I would assume that the F2 6 amp 600 volt cartridge fuse is working because I am getting power to the fan motor and everything else and it also checks good. As for the CB2 I do not have a breaker switch for this, it is a 10 amp 125 volt fuse and it checks good as well. I have tried the welder in all ranges from Low Range, Medium Range and High Range in DC reverse, DC straight and in AC in all ranges and nothing works. I have removed the left side panel looking for the F3 10 amp 250 volt fuse and cant seam to find it. My welder doesnt have the center airbaffer as shown in the manual, it does have a small round cylinder about 5/8" in diameter X 2 1/4 in lenght. It has a black wire coming out one end and a red wire coming out the other end. Could this be a small cartridge fuse? I can provide photos if needed.

    Anybody know what else I can do to fix this welder?

    Could something gone bad in the foot controller?

    Thanks

  • #2
    Did you figure out the problem

    I know this was posted a while ago but I was curious if you ever figured out the problem. I'm having the same problem and haven't had any luck on finding the issue..

    Comment


    • #3
      i have a miller 330 and hes low output power any ideas how to fix

      Comment


      • #4
        Originally posted by migweldermike View Post
        i have a miller 330 and hes low output power any ideas how to fix
        If that's as good as the question details can get, then I suggest you post your location and we can try to recommend a good repair shop.

        Comment


        • #5
          Migweldermike....please post your serial number and a detailed description of what your machine is not doing that you think it should be doing and what trouble shooting measures you have already taken.

          We had a run a few months back of guys with similar machines having trouble, so a bunch of us are fairly familiar with your welder and might be able to help if we know what help you need.

          Comment


          • #6
            Power off.....And the ohms reading from welder to torch tip is????

            Comment


            • #7
              And there is always the first question that my mind comes to.....does it stick weld?

              www.facebook.com/outbackaluminumwelding
              Miller Dynasty 700...OH YEA BABY!!
              MM 350P...PULSE SPRAYIN' MONSTER
              Miller Dynasty 280 with AC independent expansion card
              Miller Dynasty 200 DX "Blue Lightning"

              Miller Bobcat 225 NT (what I began my present Biz with!)
              Miller 30-A Spoolgun
              Miller WC-115-A
              Miller Spectrum 300
              Miller 225 Thunderbolt (my first machine bought new 1980)
              Miller Digital Elite Titanium 9400

              Comment


              • #8
                Try welding without remote contractor and remote current this will eliminate the remote control , another thing is check the ribbon resistors that are around the outside of the fan I can not remember if there are 3 or 4 , they can burn out and you will have low output or no output ( 2 of them are in parallel) Iím pretty sure all 330ABP have them

                Comment


                • #9
                  serial jb481814 when i step on the foot pedal sparks came out of the bottom and blew the fuse in back i put new fuse and it came back on but has low power at all 3 heat settings

                  Comment


                  • #10
                    Sparks came out of the bottom of the foot pedal or the bottom of the welder?

                    Comment


                    • #11
                      the welder

                      Comment


                      • #12
                        sparks came out of the bottom of the welder and blew the 6 amp fuse in back of welder i put a new fuse in and it came back on but it will only weld at low power no matter how high i set it only welds with low

                        Comment


                        • #13
                          Couldn't find a matching manual for that serial number on the website. You might have to browse the manuals until you find one that looks like your machine. I think there are two or three versions of the 330. Granted, I'm no search expert. One of the guys that is might find it straight away.

                          Comment


                          • #14
                            https://www.millerwelds.com/files/ow.../O340H_MIL.pdf

                            I think this is the correct manual. Will try to take a look this evening.

                            Comment


                            • #15
                              Wayne, I don't see a fuse in the back like he said, am missing something on the schematics?

                              Migweldermike, have you tried the suggestions from guys in above posts? Have you followed the trouble shooting chart in the manual yet? There is a section that deals directly with your reported issue, minus the Sparks show and the fuse (which I believe is on the front, but I've been wrong before).

                              Comment

                              Working...
                              X