Announcement

Collapse
No announcement yet.

Maxstar 150STL making soft clicking sounds while on, anyone else hear it?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maxstar 150STL making soft clicking sounds while on, anyone else hear it?

    I've been using my Maxstar 150stl for about a month or two now and recently noticed it making a quiet clicking/ticking sound when it is turned on. The sound comes from the back and isn't a steady click like a metronome or pocket watch but more like a random one you would hear from a geiger counter. The sound does not change when the controls are manipulated or when the unit is being used and the fan comes on. I disconnected the argon hose from the back and still no change, it functions normally and welds fine as always. just a little concerned about the noise wondering if it could be a relay or some other electronic gizmo on its way out.

    Thanks for any comments, has anyone else had this experience or can you listen to your machine and see if it is noisy too?

  • #2
    I just noticed the exact same noises from my 150STH. Can't say if they were there since I bought it brand new last year, or if it just started. I'm not too worried about it at this stage.

    Comment


    • #3
      same here

      Originally posted by pedaldude View Post
      I've been using my Maxstar 150stl for about a month or two now and recently noticed it making a quiet clicking/ticking sound when it is turned on. The sound comes from the back and isn't a steady click like a metronome or pocket watch but more like a random one you would hear from a geiger counter. The sound does not change when the controls are manipulated or when the unit is being used and the fan comes on. I disconnected the argon hose from the back and still no change, it functions normally and welds fine as always. just a little concerned about the noise wondering if it could be a relay or some other electronic gizmo on its way out.

      Thanks for any comments, has anyone else had this experience or can you listen to your machine and see if it is noisy too?
      Hello, although I have an STH, I have been using it very frequently over the summer and it always seems to make soft clicking noises. It has been making these noises since I've had it, and it has worked perfectly since then. I'm not an electrician, nor do I know what the noises mean, but I'm deducing that it is likely a normal function of the machine.

      Let us know if you hear otherwise!

      regards

      Comment


      • #4
        I noticed this thread has not been updated recently. I just detected the same noise from my STH. Anyone have an answer to the question as to what the noise is?

        Comment


        • #5
          Update on Maxstar 150STH Clicking

          Per Jeff at Miller on 5-22-13: The soft clicking sound at the rear of the Maxstar is a normal condition. It is caused by the Auto-Line circuit. It can occur intermitently depending on the condition of the input voltage.
          Last edited by idahoguy; 05-28-2013, 11:11 PM.

          Comment


          • #6
            Same here

            I've had my STH for 3 yrs now and it has always made that sound. I did contact Miller about it several years back and they confirmed same as above.

            Comment


            • #7
              If Miller just added a really loud fan that ran continuously, it wouldn't be a problem.
              Miller stuff:
              Dialarc 250 (1974)
              Syncrowave 250 (1992)
              Spot welder (Dayton badged)

              Comment


              • #8
                That sound that you are hearing are the MOD's. It sounds kind of like bacon frying but not as loud. Have even heard it referred to as "crickets".

                Comment

                Working...
                X