Miller Electric

Welding Discussion Forums

Home » Resources » Communities » Welding Discussion Forums

  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Announcement

Announcement Module
Collapse
No announcement yet.

Econotig Problems

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Econotig Problems

    Here goes the problem:

    I have just joined a club here at school and we have an Econotig SN# KJ063776. Whenever we try to TIG weld with it it seems as if it is going full current.
    We started with the peddle and A to B closes as it should when the peddle is initially pressed. Also, E to C and E to D both swing the full 1k range, inverse from one another as the pot should.
    From there we ventured into the machine itself and checked the amp percentage knob on the front. From the molex connector, we checked the ohm to the control knob and that too swung from 0 to about 1k ohm.

    That is where I left it to come seek further advice.

    Thanks,
    Brian

  • #2
    Your hall device (lem) is likely hooped, quite common failure in the small tigs

    Comment


    • #3
      I'm looking at the part breakdown but at the moment I'm at a loss to find the hall sensor. The closest thing I could think of is the blocking transformer. I have no idea if that is it or not.

      Brian

      Comment

      Working...
      X
      Special Offers: See the latest Miller deals and promotions.