No announcement yet.

mm251 not working right need help ASAP

  • Filter
  • Time
  • Show
Clear All
new posts

  • mm251 not working right need help ASAP

    So I've got something that has to be done tonight and I go to fire up the welder and the gas solenoid is stuck on. I did some checking and this is what I found;
    The gas solenoid is energized all the time the only way to shut it off is to unplug it right at the solenoid. The trigger has no effect.
    The trigger works for wire feed and weld output the way it is supposed to.
    The welding output voltage seems to be through the roof, although the meters seem to be registering alright.

    Please Help !!

  • #2
    first i would blow out the machine with air after removing the covers. then if that does not help call ur local welding shop for trouble shooting and parts or the repair its self.
    trail blazer 302
    hypertherm plasma
    millermatic 251
    high feq. arc starter
    suit case (extreme 12vs)
    o/a torches
    way to many other tools to list


    • #3
      Unplug the gun trigger harness, does your gas go off?

      If it does then loop a piece of mig wire into the plug on pins 1&2 and see if the unit performs correctly, you may have a shorted gun:

      If you have the cover off, and no power connected to the unit, check your output SCR block for looseness or damage, right side, center lower.
      Last edited by cruizer; 06-02-2008, 06:12 PM.


      • #4
        I unplugged the gun previously & it did not change anything( the trigger operates the wire feed fine). Unplugging the trigger contacts at the main board doesn't help either. everything inside looks ok(what's the scr?) It does not look like I let the smoke out of anything. What baffles me is the unusually high output. with the wfs at 225 to 250 and the voltage all the way down it is nearly in spray with 80/20.

        Breaking out the econotig right now.


        • #5
          This unit should still be under warranty. I think I'll call my LWS tomorrow and see what they have to say.


          • #6
            It's been in the shop since the 5th or 6th still waiting to hear back & see what the diagnosis is.


            • #7
              Picked it back up late last week. It got a new circuit board and al seems well though i've only welded about 2 inches with it. I'll put some time on it soon though.